aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Tricca <flihp@twobit.us>2014-04-16 01:16:48 +0000
committerSaul Wold <sgw@linux.intel.com>2014-05-23 09:09:39 -0700
commit63ce29a48b608f34dd378285a54c24ee83a3a1c7 (patch)
treeba756233f055e68b0d46d2f0a85fa2fa135f9c7f
parent8f5a97d6ed8b4e2f85a834b641f19ad843522aa1 (diff)
downloadopenembedded-core-contrib-63ce29a48b608f34dd378285a54c24ee83a3a1c7.tar.gz
grub-efi: Use a variable to specify built-in grub modules.
The previous behavior defines a static set of modules that are built into the grub efi executable. This works fine for a limited set of boot environments namely the standard linux/initrd. This patch conditionally assigns the same modules to a variable. This allows other meta layers to add additional modules or completely override the defaults. The use case driving this patch is the use of multiboot2 and related modules. (From OE-Core rev: 597f8e0040ba3135220000b23767858c64b5c9b8) Signed-off-by: Philip Tricca <flihp@twobit.us> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.00.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.00.bb b/meta/recipes-bsp/grub/grub-efi_2.00.bb
index 6944cb280e..4b43749200 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.00.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.00.bb
@@ -70,12 +70,14 @@ do_install_class-native() {
install -m 755 grub-mkimage ${D}${bindir}
}
+GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search"
+
do_deploy() {
# Search for the grub.cfg on the local boot media by using the
# built in cfg file provided via this recipe
grub-mkimage -c ../cfg -p /EFI/BOOT -d ./grub-core/ \
-O ${GRUB_TARGET}-efi -o ./${GRUB_IMAGE} \
- boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search
+ ${GRUB_BUILDIN}
install -m 644 ${B}/${GRUB_IMAGE} ${DEPLOYDIR}
}