aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2015-10-22 14:58:18 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 07:56:49 +0000
commit784f4c80204a09b85b7e83c9bd91cd48f001384f (patch)
treeac12ff9275aefeb0b11671e79a3aafdcc15628d6
parent1c0cfffee21e99a7356c9046c86628bc0acf654c (diff)
downloadopenembedded-core-contrib-784f4c80204a09b85b7e83c9bd91cd48f001384f.tar.gz
base-files: stage /etc/skel
Having skel in the staging area lets other recipes access these files. For ex. recipes inheriting useradd, if passing "-m" to USERADD_PARAM, .bashrc and .profile are put automatically in $HOME, as expected. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/base-files/base-files_3.0.14.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/base-files/base-files_3.0.14.bb b/meta/recipes-core/base-files/base-files_3.0.14.bb
index e16fe722b8..b71d5c5341 100644
--- a/meta/recipes-core/base-files/base-files_3.0.14.bb
+++ b/meta/recipes-core/base-files/base-files_3.0.14.bb
@@ -167,6 +167,10 @@ do_install_append_linuxstdbase() {
done
}
+sysroot_stage_all_append () {
+ sysroot_stage_dir ${D}${sysconfdir}/skel ${SYSROOT_DESTDIR}${sysconfdir}/skel
+}
+
PACKAGES = "${PN}-doc ${PN} ${PN}-dev ${PN}-dbg"
FILES_${PN} = "/"
FILES_${PN}-doc = "${docdir} ${datadir}/common-licenses"