aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-01-05 10:53:42 +0800
committerChen Qi <Qi.Chen@windriver.com>2015-01-05 11:00:54 +0800
commite92ca9f3b22c791270d9320bd764b200ef4452b2 (patch)
tree0f53613359cb0c07cda0e2c0dc5646d894d32f46
parent24f19fedb40d0af84beb8e9a6595ea06f09d4615 (diff)
downloadopenembedded-core-contrib-e92ca9f3b22c791270d9320bd764b200ef4452b2.tar.gz
cmake-native: disable check for acl.hChenQi/cmake-native-acl
We build cmake-native without acl support. However, the acl.h header is still being checked which would sometimes cause the following error during do_compile: archive_read_disk_entry_from_file.c:38:21: fatal error: sys/acl.h: No such file or directory | #include <sys/acl.h> | ^ | compilation terminated. This happens when the sysroot parts of acl-native is removed between do_configure and do_compile tasks of cmake-native. To reproduce the problem manually, execute the following command: bitbake cmake-native -c cleansstate && bitbake acl-native -c cleansstate && \ bitbake acl-native && bitbake cmake-native -c configure && \ bitbake acl-native -c cleansstate && bitbake cmake-native -c compile This patch fixes the above problem by explicitly disable the checking for acl.h header file. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb b/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
index cd6b1d8845..e40dfdd2d8 100644
--- a/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_2.8.12.2.bb
@@ -15,4 +15,5 @@ SRC_URI[sha256sum] = "8c6574e9afabcb9fc66f463bb1f2f051958d86c85c37fccf067eb1a44a
CMAKE_EXTRACONF = "\
-DBUILD_CursesDialog=0 \
-DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
+ -DHAVE_SYS_ACL_H=0 \
"