aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-12-02 18:26:06 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-05 17:42:46 +0000
commit26518bea1d6aa0e438e6492c2af70225b431d7a1 (patch)
tree07a67de6b0252dadbeb0784a3059abf19f1147f0
parent9abb72664b27cf5fbde50283b2a877ce546c3d43 (diff)
downloadopenembedded-core-contrib-26518bea1d6aa0e438e6492c2af70225b431d7a1.tar.gz
bootchart2: fix to find collector correctly in case of multilib
This patch fixes the following error of being not able to find the bootchart-collector program when using bootchart2 in multilib system. In order for bootchartd to correctly find the collector program, we need to set several vars while compiling. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_git.bb b/meta/recipes-devtools/bootchart2/bootchart2_git.bb
index 04fb901b68..5fc7211f79 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_git.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_git.bb
@@ -120,6 +120,12 @@ do_compile_append_class-native () {
chmod +x ${S}/pybootchartgui
}
+do_compile_prepend () {
+ export PY_LIBDIR="${libdir}/${PYTHON_DIR}"
+ export BINDIR="${bindir}"
+ export LIBDIR="${base_libdir}"
+}
+
do_install () {
install -d ${D}${sysconfdir} # needed for -native
export PY_LIBDIR="${libdir}/${PYTHON_DIR}"