aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-03-11 14:07:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-20 22:57:58 +0000
commite1108fa41742e726aa578d0298fa6397b2663ff3 (patch)
tree26efffbf1d9312d09a337f59fc82945d199f2917
parenta6e7a86f1635be9a688c56c25e9d215ea4d2cc84 (diff)
downloadopenembedded-core-contrib-e1108fa41742e726aa578d0298fa6397b2663ff3.tar.gz
smartpm: remove rpm4 patch
The RPM4 support we added to SMART doesn't appear to work, remove it as part of the removal of RPM4 from OE-Core. Refresh the smart-add-for-rpm-ignoresize-check.patch which was applied after smart-rpm4-fixes.patch and doesn't apply cleanly once that patch is removed. Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-add-for-rpm-ignoresize-check.patch20
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-rpm4-fixes.patch49
-rw-r--r--meta/recipes-devtools/python/python-smartpm_git.bb1
3 files changed, 9 insertions, 61 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-add-for-rpm-ignoresize-check.patch b/meta/recipes-devtools/python/python-smartpm/smart-add-for-rpm-ignoresize-check.patch
index 8a27f2583a..fe98d070d3 100644
--- a/meta/recipes-devtools/python/python-smartpm/smart-add-for-rpm-ignoresize-check.patch
+++ b/meta/recipes-devtools/python/python-smartpm/smart-add-for-rpm-ignoresize-check.patch
@@ -17,14 +17,15 @@ Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
smart/backends/rpm/pm.py | 4 ++++
1 file changed, 4 insertions(+)
-diff --git a/smart/backends/rpm/pm.py b/smart/backends/rpm/pm.py
-index 5da9ee6..f0488ec 100644
---- a/smart/backends/rpm/pm.py
-+++ b/smart/backends/rpm/pm.py
-@@ -241,6 +241,10 @@ class RPMPackageManager(PackageManager):
- except AttributeError:
- probfilter |= rpm.RPMPROB_FILTER_IGNOREARCH
-
+Index: git/smart/backends/rpm/pm.py
+===================================================================
+--- git.orig/smart/backends/rpm/pm.py
++++ git/smart/backends/rpm/pm.py
+@@ -233,6 +233,11 @@ class RPMPackageManager(PackageManager):
+ if sysconf.get("rpm-order"):
+ ts.order()
+ probfilter = rpm.RPMPROB_FILTER_OLDPACKAGE
++
+ if sysconf.get("rpm-ignoresize", False):
+ probfilter |= rpm.RPMPROB_FILTER_DISKNODES
+ probfilter |= rpm.RPMPROB_FILTER_DISKSPACE
@@ -32,6 +33,3 @@ index 5da9ee6..f0488ec 100644
if force or reinstall:
probfilter |= rpm.RPMPROB_FILTER_REPLACEPKG
probfilter |= rpm.RPMPROB_FILTER_REPLACEOLDFILES
---
-1.9.1
-
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-rpm4-fixes.patch b/meta/recipes-devtools/python/python-smartpm/smart-rpm4-fixes.patch
deleted file mode 100644
index 708ffe67d3..0000000000
--- a/meta/recipes-devtools/python/python-smartpm/smart-rpm4-fixes.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-
-This patch checks for rpm5 related functions in order to allow rpm4
-to work correctly. Currently the rpm4 archscore and filter work
-differently enough that they need to be changed.
-
-Upstream-Status: Inappropriate [OE-Core Specific]
-
-Signed-off-by: Saul Wold <sgw@linux.intel.com>
-
-Index: smart-1.4.1/smart/backends/rpm/base.py
-===================================================================
---- smart-1.4.1.orig/smart/backends/rpm/base.py
-+++ smart-1.4.1/smart/backends/rpm/base.py
-@@ -338,10 +338,14 @@ class RPMObsoletes(Depends):
-
- _SCOREMAP = {}
- def getArchScore(arch, _sm=_SCOREMAP):
-- if arch not in _sm:
-- score = rpm.archscore(arch)
-- _sm[arch] = score
-- return _sm.get(arch, 0)
-+ try:
-+ rpm.platformscore(arch)
-+ if arch not in _sm:
-+ score = rpm.archscore(arch)
-+ _sm[arch] = score
-+ return _sm.get(arch, 0)
-+ except AttributeError:
-+ return 1
-
- # TODO: Embed color into nameprovides and obsoletes relations.
- _COLORMAP = {"noarch": 0, "x86_64": 2, "ppc64": 2, "s390x": 2, "sparc64": 2}
-Index: smart-1.4.1/smart/backends/rpm/pm.py
-===================================================================
---- smart-1.4.1.orig/smart/backends/rpm/pm.py
-+++ smart-1.4.1/smart/backends/rpm/pm.py
-@@ -235,6 +235,12 @@ class RPMPackageManager(PackageManager):
- if sysconf.get("rpm-order"):
- ts.order()
- probfilter = rpm.RPMPROB_FILTER_OLDPACKAGE
-+ try:
-+ # Test for RPM5 function
-+ rpm.platformscore("")
-+ except AttributeError:
-+ probfilter |= rpm.RPMPROB_FILTER_IGNOREARCH
-+
- if force or reinstall:
- probfilter |= rpm.RPMPROB_FILTER_REPLACEPKG
- probfilter |= rpm.RPMPROB_FILTER_REPLACEOLDFILES
diff --git a/meta/recipes-devtools/python/python-smartpm_git.bb b/meta/recipes-devtools/python/python-smartpm_git.bb
index 139bfd5802..d9a908db2e 100644
--- a/meta/recipes-devtools/python/python-smartpm_git.bb
+++ b/meta/recipes-devtools/python/python-smartpm_git.bb
@@ -19,7 +19,6 @@ SRC_URI = "\
file://smart-channelsdir.patch \
file://smart-attempt.patch \
file://smart-attempt-fix.patch \
- file://smart-rpm4-fixes.patch \
file://smart-add-for-rpm-ignoresize-check.patch \
file://smart-already-installed-message.patch \
file://smart-set-noprogress-for-pycurl.patch \