aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-10-10 08:20:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-10-10 16:29:01 +0100
commit5f225067dcb7244065f857d34e1041171844b243 (patch)
treee92afe19d9c4ae4d23239aa9bbcd8ee801e641c1
parent2d9466734f0c0c90724820bc36992b2800ffa4d0 (diff)
downloadopenembedded-core-contrib-5f225067dcb7244065f857d34e1041171844b243.tar.gz
glibc: remove bad patch snippet that eglibc forward ported
The s_sin.c patch undoes some code changes in glibc itself, these changes have nothing to do with the option groups and I suspect crept in as part of the initial conversion. Undoing this patch also fixes a test failure in test-double and test-idouble. [YOCTO #6808] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch b/meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch
index f53a8994fc..40c783212a 100644
--- a/meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch
+++ b/meta/recipes-core/glibc/glibc/eglibc-use-option-groups.patch
@@ -15454,60 +15454,6 @@ Index: git/sysdeps/gnu/Makefile
pututxline utmpxname updwtmpx getutmpx getutmp
sysdep_headers += utmpx.h bits/utmpx.h
-Index: git/sysdeps/ieee754/dbl-64/s_sin.c
-===================================================================
---- git.orig/sysdeps/ieee754/dbl-64/s_sin.c 2014-08-29 20:00:54.260070587 -0700
-+++ git/sysdeps/ieee754/dbl-64/s_sin.c 2014-08-29 20:01:15.240070587 -0700
-@@ -447,21 +447,19 @@
- }
- else
- {
-- double t;
- if (a > 0)
- {
- m = 1;
-- t = a;
- db = da;
- }
- else
- {
- m = 0;
-- t = -a;
-+ a = -a;
- db = -da;
- }
-- u.x = big + t;
-- y = t - (u.x - big);
-+ u.x = big + a;
-+ y = a - (u.x - big);
- res = do_sin (u, y, db, &cor);
- cor = (cor > 0) ? 1.035 * cor + eps : 1.035 * cor - eps;
- retval = ((res == res + cor) ? ((m) ? res : -res)
-@@ -673,21 +671,19 @@
- }
- else
- {
-- double t;
- if (a > 0)
- {
- m = 1;
-- t = a;
- db = da;
- }
- else
- {
- m = 0;
-- t = -a;
-+ a = -a;
- db = -da;
- }
-- u.x = big + t;
-- y = t - (u.x - big);
-+ u.x = big + a;
-+ y = a - (u.x - big);
- res = do_sin (u, y, db, &cor);
- cor = (cor > 0) ? 1.035 * cor + eps : 1.035 * cor - eps;
- retval = ((res == res + cor) ? ((m) ? res : -res)
Index: git/sysdeps/ieee754/ldbl-opt/Makefile
===================================================================
--- git.orig/sysdeps/ieee754/ldbl-opt/Makefile 2014-08-29 20:00:54.452070587 -0700