aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAwais Belal <awais_belal@mentor.com>2016-06-14 16:26:08 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 17:36:36 +0100
commit20c637ef40f2de9c2848ac1fb25240dea84cdb7b (patch)
tree84ed7870c3d20c9ac11f63ff851b792fe858c84c
parent85630aa894278e7818c867179dc19ca2fbd994fc (diff)
downloadopenembedded-core-contrib-20c637ef40f2de9c2848ac1fb25240dea84cdb7b.tar.gz
python3: fix CROSSPYTHONPATH for cross builds
There are cases where target and host are of the same type and at such instances the target modules may be loaded if CROSSPYTHONPATH is not correct. This adds host library paths so that target modules are not loaded while cross compiling to avoid illegal instruction issues. Signed-off-by: Awais Belal <awais_belal@mentor.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3_3.5.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3_3.5.1.bb b/meta/recipes-devtools/python/python3_3.5.1.bb
index ebfdcdb749..78ae1740e3 100644
--- a/meta/recipes-devtools/python/python3_3.5.1.bb
+++ b/meta/recipes-devtools/python/python3_3.5.1.bb
@@ -70,8 +70,8 @@ export _PYTHON_PROJECT_BASE = "${B}"
export _PYTHON_PROJECT_SRC = "${S}"
export CCSHARED = "-fPIC"
-# Fix ctypes cross compilation
-export CROSSPYTHONPATH = "${B}/build/lib.linux-${TARGET_ARCH}-${PYTHON_MAJMIN}:${S}/Lib:${S}/Lib/plat-linux"
+# Fix cross compilation of different modules
+export CROSSPYTHONPATH = "${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/:${B}/build/lib.linux-${TARGET_ARCH}-${PYTHON_MAJMIN}:${S}/Lib:${S}/Lib/plat-linux"
# No ctypes option for python 3
PYTHONLSBOPTS = ""