aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-12-29 17:39:11 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-07 13:40:05 +0000
commit8a96dbe5dd44e1c80aef7b8efe5820dee96a5bd7 (patch)
tree0dc0777318e45548c9d67581f3e592fe408c4448
parent849abbb0a779cfc4a6f5bbde49ba41e005e65fa8 (diff)
downloadopenembedded-core-contrib-8a96dbe5dd44e1c80aef7b8efe5820dee96a5bd7.tar.gz
python3: fix installed-vs-shipped when 64bit + multilib
Fixed: python3-3.5.0: python3: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/python3.5 /usr/lib/python3.5/config-3.5m /usr/lib/python3.5/config-3.5m/python.o /usr/lib/python3.5/config-3.5m/Setup.local /usr/lib/python3.5/config-3.5m/Setup /usr/lib/python3.5/config-3.5m/python-config.py /usr/lib/python3.5/config-3.5m/install-sh /usr/lib/python3.5/config-3.5m/config.c.in /usr/lib/python3.5/config-3.5m/makesetup /usr/lib/python3.5/config-3.5m/Setup.config /usr/lib/python3.5/config-3.5m/config.c /usr/lib/python3.5/config-3.5m/Makefile /usr/lib/python3.5/config-3.5m/libpython3.5m.a Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. python3: 14 installed and not shipped files. [installed-vs-shipped] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3/configure.ac-fix-LIBPL.patch30
-rw-r--r--meta/recipes-devtools/python/python3_3.5.0.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/configure.ac-fix-LIBPL.patch b/meta/recipes-devtools/python/python3/configure.ac-fix-LIBPL.patch
new file mode 100644
index 0000000000..97214f9aa4
--- /dev/null
+++ b/meta/recipes-devtools/python/python3/configure.ac-fix-LIBPL.patch
@@ -0,0 +1,30 @@
+From 7c4f8d87473d6238c120ec6031b58f83a17a39a5 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Mon, 28 Dec 2015 22:52:06 -0800
+Subject: [PATCH] configure.ac: fix LIBPL
+
+Use LIBDIR rather than prefix/lib, so that it would work when lib64.
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 63aef8e..aefb27f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -4366,7 +4366,7 @@ AC_MSG_RESULT($LDVERSION)
+
+ dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
+ AC_SUBST(PY_ENABLE_SHARED)
+-LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
++LIBPL='$(LIBDIR)'"/python${VERSION}/config-${LDVERSION}"
+ AC_SUBST(LIBPL)
+
+ # Check whether right shifting a negative integer extends the sign bit
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/python/python3_3.5.0.bb b/meta/recipes-devtools/python/python3_3.5.0.bb
index a5663a1e25..d5e26ff764 100644
--- a/meta/recipes-devtools/python/python3_3.5.0.bb
+++ b/meta/recipes-devtools/python/python3_3.5.0.bb
@@ -37,6 +37,7 @@ SRC_URI += "\
file://setup.py-check-cross_compiling-when-get-FLAGS.patch \
file://setup.py-find-libraries-in-staging-dirs.patch \
file://use_packed_importlib.patch \
+ file://configure.ac-fix-LIBPL.patch \
"
SRC_URI[md5sum] = "d149d2812f10cbe04c042232e7964171"
SRC_URI[sha256sum] = "d6d7aa1634a5eeeca6ed4fca266982a04f84bd8f3945a9179e20b24ad2e2be91"