aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2015-07-28 16:58:37 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-01 10:59:26 +0100
commitff3633fa6a379d502f65b20d6a57d30c59f09ab6 (patch)
treedd339a9b5c070f7f7d33fc97d6997433009484fc
parent9e01909f3239f0a88e20f12e65b6141e547b114a (diff)
downloadopenembedded-core-contrib-ff3633fa6a379d502f65b20d6a57d30c59f09ab6.tar.gz
python3: remove 2to3 symlink from package python3-2to3
The 2to3 symlink conflicts with its Python 2 equivalent in package python-2to3. The Python 3 version of the tool is still available as 2to3-3.4. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-3.4-manifest.inc2
-rw-r--r--meta/recipes-devtools/python/python3_3.4.3.bb3
-rwxr-xr-xscripts/contrib/python/generate-manifest-3.4.py2
3 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python-3.4-manifest.inc b/meta/recipes-devtools/python/python-3.4-manifest.inc
index 77f01254e2..07e1490273 100644
--- a/meta/recipes-devtools/python/python-3.4-manifest.inc
+++ b/meta/recipes-devtools/python/python-3.4-manifest.inc
@@ -11,7 +11,7 @@ PACKAGES="${PN}-dbg ${PN}-2to3 ${PN}-asyncio ${PN}-audio ${PN}-codecs ${PN}-comp
SUMMARY_${PN}-2to3="Python automated Python 2 to 3 code translator"
RDEPENDS_${PN}-2to3="${PN}-core"
-FILES_${PN}-2to3="${bindir}/2to3 ${libdir}/python3.4/lib2to3 "
+FILES_${PN}-2to3="${libdir}/python3.4/lib2to3 "
SUMMARY_${PN}-asyncio="Python Asynchronous I/O, event loop, coroutines and tasks"
RDEPENDS_${PN}-asyncio="${PN}-core"
diff --git a/meta/recipes-devtools/python/python3_3.4.3.bb b/meta/recipes-devtools/python/python3_3.4.3.bb
index e2d9f796f1..6c2e21d6a9 100644
--- a/meta/recipes-devtools/python/python3_3.4.3.bb
+++ b/meta/recipes-devtools/python/python3_3.4.3.bb
@@ -162,6 +162,9 @@ do_install() {
ARCH=${TARGET_ARCH} \
DESTDIR=${D} LIBDIR=${libdir} install
+ # avoid conflict with 2to3 from Python 2
+ rm -f ${D}/${bindir}/2to3
+
install -m 0644 Makefile.sysroot ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
if [ -e ${WORKDIR}/sitecustomize.py ]; then
diff --git a/scripts/contrib/python/generate-manifest-3.4.py b/scripts/contrib/python/generate-manifest-3.4.py
index 42c851c11a..06eecdc5d0 100755
--- a/scripts/contrib/python/generate-manifest-3.4.py
+++ b/scripts/contrib/python/generate-manifest-3.4.py
@@ -194,7 +194,7 @@ if __name__ == "__main__":
"${datadir}/pkgconfig " )
m.addPackage( "${PN}-2to3", "Python automated Python 2 to 3 code translator", "${PN}-core",
- "${bindir}/2to3 lib2to3" ) # package
+ "lib2to3" ) # package
m.addPackage( "${PN}-idle", "Python Integrated Development Environment", "${PN}-core ${PN}-tkinter",
"${bindir}/idle idlelib" ) # package