aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-07-30 13:56:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-01 10:49:21 +0100
commit4d9a9d748e4cd0d0ffc67907c06bd01ceda2722e (patch)
tree47d7337473f6fba20afbd862ffbd3097e6947501
parentb5e91f26b2779178765b62df36421d97caa4cdd7 (diff)
downloadopenembedded-core-contrib-4d9a9d748e4cd0d0ffc67907c06bd01ceda2722e.tar.gz
busybox: enable support for sha1sum and sha256sum applets
Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/busybox/busybox/sha1sum.cfg1
-rw-r--r--meta/recipes-core/busybox/busybox/sha256sum.cfg1
-rw-r--r--meta/recipes-core/busybox/busybox_1.23.2.bb2
-rw-r--r--meta/recipes-core/busybox/busybox_git.bb2
4 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/sha1sum.cfg b/meta/recipes-core/busybox/busybox/sha1sum.cfg
new file mode 100644
index 0000000000..20e72d9263
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/sha1sum.cfg
@@ -0,0 +1 @@
+CONFIG_SHA1SUM=y
diff --git a/meta/recipes-core/busybox/busybox/sha256sum.cfg b/meta/recipes-core/busybox/busybox/sha256sum.cfg
new file mode 100644
index 0000000000..ce652ae4c6
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/sha256sum.cfg
@@ -0,0 +1 @@
+CONFIG_SHA256SUM=y
diff --git a/meta/recipes-core/busybox/busybox_1.23.2.bb b/meta/recipes-core/busybox/busybox_1.23.2.bb
index b84f499648..8a4bae692a 100644
--- a/meta/recipes-core/busybox/busybox_1.23.2.bb
+++ b/meta/recipes-core/busybox/busybox_1.23.2.bb
@@ -33,6 +33,8 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://0001-ifconfig-fix-double-free-fatal-error-in-INET_sprint.patch \
file://0001-chown-fix-help-text.patch \
file://mount-via-label.cfg \
+ file://sha1sum.cfg \
+ file://sha256sum.cfg \
"
SRC_URI[tarball.md5sum] = "7925683d7dd105aabe9b6b618d48cc73"
diff --git a/meta/recipes-core/busybox/busybox_git.bb b/meta/recipes-core/busybox/busybox_git.bb
index 71e6c13b71..ade72f4b71 100644
--- a/meta/recipes-core/busybox/busybox_git.bb
+++ b/meta/recipes-core/busybox/busybox_git.bb
@@ -39,6 +39,8 @@ SRC_URI = "git://busybox.net/busybox.git \
file://0001-ifconfig-fix-double-free-fatal-error-in-INET_sprint.patch \
file://0001-chown-fix-help-text.patch \
file://mount-via-label.cfg \
+ file://sha1sum.cfg \
+ file://sha256sum.cfg \
"
EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"