aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2015-07-24 13:48:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-31 10:31:01 +0100
commit48e04a93c357fb494470d2f175e644a6f43a7d63 (patch)
treead02fc36649de6f4f725bda24622042f869002c1
parent48d735a8938ec7c49754a57019182ebcd9a2d8b6 (diff)
downloadopenembedded-core-contrib-48e04a93c357fb494470d2f175e644a6f43a7d63.tar.gz
opkg-utils: use ${bindir} instead of hardcoding /usr/bin
Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index 2f66632b66..5f518d22d1 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -28,6 +28,10 @@ do_install() {
oe_runmake PREFIX=${prefix} DESTDIR=${D} install
}
+do_install_append_class-target() {
+ sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${libdir},g'
+}
+
PACKAGES =+ "update-alternatives-opkg"
FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"