aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2015-07-24 13:48:47 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-31 10:31:01 +0100
commit48d735a8938ec7c49754a57019182ebcd9a2d8b6 (patch)
tree36fdd3f56d5cd6013b10b7bdc9e2a65e14ac047d
parent5f3f4196988675e9be5aea8eac56687641b90c10 (diff)
downloadopenembedded-core-contrib-48d735a8938ec7c49754a57019182ebcd9a2d8b6.tar.gz
run-postinsts: use ${localstatedir} instead of hardcoding /var/lib
Signed-off-by: Ross Burton <ross.burton@intel.com>
-rwxr-xr-xmeta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts2
-rw-r--r--meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb1
2 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts b/meta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts
index ac9cee678b..58ea85e114 100755
--- a/meta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts/run-postinsts
@@ -20,7 +20,7 @@ for pm in $backend_list; do
case $pm in
"deb")
- if [ -s "/var/lib/dpkg/status" ]; then
+ if [ -s "#LOCALSTATEDIR#/lib/dpkg/status" ]; then
pm_installed=true
break
fi
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
index d126132a87..11c94e57d8 100644
--- a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
@@ -39,6 +39,7 @@ do_install() {
sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' \
-e 's:#SBINDIR#:${sbindir}:g' \
-e 's:#BASE_BINDIR#:${base_bindir}:g' \
+ -e 's:#LOCALSTATEDIR#:${localstatedir}:g' \
${D}${sbindir}/run-postinsts \
${D}${systemd_unitdir}/system/run-postinsts.service
}