aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-07-30 14:37:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-31 15:35:34 +0100
commit0d1f99fe1446edfb8864cbbc5a8b0059391c9bbc (patch)
tree5e26e5da0198143049631dc45f77146cdcfd7ee7
parenteba55c2c263af2973de612c003cc616ce3e22221 (diff)
downloadopenembedded-core-contrib-0d1f99fe1446edfb8864cbbc5a8b0059391c9bbc.tar.gz
smartpm: set noprogress for pycurl
Set NOPROGRESS for pycurl just as same as default operation in pycurl module itself. If set NOPROGRESS with 0 for pycurl, it causes dead lock issue of Python GIL when call smart library by python gui just like pygtk. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-set-noprogress-for-pycurl.patch20
-rw-r--r--meta/recipes-devtools/python/python-smartpm_git.bb1
2 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-set-noprogress-for-pycurl.patch b/meta/recipes-devtools/python/python-smartpm/smart-set-noprogress-for-pycurl.patch
new file mode 100644
index 0000000000..2885998acc
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm/smart-set-noprogress-for-pycurl.patch
@@ -0,0 +1,20 @@
+Set NOPROGRESS for pycurl just as same as default operation in pycurl module itself.
+If set NOPROGRESS with 0 for pycurl, it causes dead lock issue of Python GIL when
+call smart library by python gui just like pygtk.
+
+Upstream-Status: Pending
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+---
+diff -u smart-1.4.1/smart.orig/fetcher.py smart-1.4.1/smart/fetcher.py
+--- smart-1.4.1/smart.orig/fetcher.py 2014-07-15 16:42:19.240437080 +0800
++++ smart-1.4.1/smart/fetcher.py 2014-07-15 17:02:37.812470289 +0800
+@@ -1720,7 +1720,7 @@
+ handle.setopt(pycurl.OPT_FILETIME, 1)
+ handle.setopt(pycurl.LOW_SPEED_LIMIT, 1)
+ handle.setopt(pycurl.LOW_SPEED_TIME, SOCKETTIMEOUT)
+- handle.setopt(pycurl.NOPROGRESS, 0)
++ handle.setopt(pycurl.NOPROGRESS, 1)
+ handle.setopt(pycurl.PROGRESSFUNCTION, progress)
+ handle.setopt(pycurl.WRITEDATA, local)
+ handle.setopt(pycurl.FOLLOWLOCATION, 1)
diff --git a/meta/recipes-devtools/python/python-smartpm_git.bb b/meta/recipes-devtools/python/python-smartpm_git.bb
index 163461e592..8b974b0c33 100644
--- a/meta/recipes-devtools/python/python-smartpm_git.bb
+++ b/meta/recipes-devtools/python/python-smartpm_git.bb
@@ -22,6 +22,7 @@ SRC_URI = "\
file://smart-rpm4-fixes.patch \
file://smart-add-for-rpm-ignoresize-check.patch \
file://smart-already-installed-message.patch \
+ file://smart-set-noprogress-for-pycurl.patch \
"
SRCREV = "407a7eca766431257dcd1da15175cc36a1bb22d0"