aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-05-14 16:21:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-08 17:32:43 +0100
commite4dd43cb88a582e4b5116c499ea8131539a3c5b9 (patch)
treea6de08a7586815b612404a0066b132126f92ae05
parent66c6d0db27c4ab7b633e6954d095c411a98b67f4 (diff)
downloadopenembedded-core-contrib-e4dd43cb88a582e4b5116c499ea8131539a3c5b9.tar.gz
python3: Fix distutils import error
The patch 12-distutils-prefix-is-inside-staging-area.patch is used to fix problems when trying to get some environmental variables but it is only necessary for python3-native, on python3-core it causes an error when importing distutils since env variables of the likes of HOST_SYS and such do not exist on target, this removes the patch from python3-core so distutils can be imported correctly. [YOCTO #7766] Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python3_3.4.3.bb1
1 files changed, 0 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3_3.4.3.bb b/meta/recipes-devtools/python/python3_3.4.3.bb
index 5ef17e6399..4bab4db81b 100644
--- a/meta/recipes-devtools/python/python3_3.4.3.bb
+++ b/meta/recipes-devtools/python/python3_3.4.3.bb
@@ -7,7 +7,6 @@ PYTHON_BINABI= "${PYTHON_MAJMIN}m"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
DISTRO_SRC_URI_linuxstdbase = ""
SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
-file://12-distutils-prefix-is-inside-staging-area.patch \
file://python-config.patch \
file://000-cross-compile.patch \
file://020-dont-compile-python-files.patch \