aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-02-05 01:48:41 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-14 22:26:10 +0000
commit2f7ae00803bec32dabb75ece86b6d4a858e512d1 (patch)
tree1f753c45e34c95f19f80b65f8ef29290cc3b7c3b
parent065f4034698caaaab9c8076d3c7e4ebafb8a9353 (diff)
downloadopenembedded-core-contrib-2f7ae00803bec32dabb75ece86b6d4a858e512d1.tar.gz
pcmciautils: fix and enable parallel build
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-bsp/pcmciautils/pcmciautils-018/Makefile-fix-for-parallel-build.patch35
-rw-r--r--meta/recipes-bsp/pcmciautils/pcmciautils.inc1
-rw-r--r--meta/recipes-bsp/pcmciautils/pcmciautils_018.bb4
3 files changed, 38 insertions, 2 deletions
diff --git a/meta/recipes-bsp/pcmciautils/pcmciautils-018/Makefile-fix-for-parallel-build.patch b/meta/recipes-bsp/pcmciautils/pcmciautils-018/Makefile-fix-for-parallel-build.patch
new file mode 100644
index 0000000000..e9eaab780d
--- /dev/null
+++ b/meta/recipes-bsp/pcmciautils/pcmciautils-018/Makefile-fix-for-parallel-build.patch
@@ -0,0 +1,35 @@
+From 1b8ad348f8c712c8e0c16c49cc1c8e577e4d6d3e Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Thu, 5 Feb 2015 01:16:30 -0800
+Subject: [PATCH] Makefile: fix for parallel build
+
+Fixed:
+| src/lex_config.c:34:25: fatal error: yacc_config.h: No such file or directory
+|
+| #include "yacc_config.h"
+| ^
+| compilation terminated.
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index d45fdc3..de2a5f9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -246,7 +246,7 @@ $(PCMCIA_SOCKET_STARTUP): $(LIBC) src/startup.o src/yacc_config.o src/lex_config
+ $(QUIET) $(LD) $(LDFLAGS) -o $@ $(CRT0) src/startup.o src/yacc_config.o src/lex_config.o $(LIB_OBJS) $(ARCH_LIB_OBJS)
+ $(QUIET) $(STRIPCMD) $@
+
+-yacc_config.o lex_config.o: %.o: %.c
++yacc_config.o lex_config.o: %.o: %.c: %.h
+ $(CC) -c -MD -O -pipe $(CPPFLAGS) $<
+
+ debugtools: ccdv $(CBDUMP) $(CISDUMP)
+--
+1.7.9.5
+
diff --git a/meta/recipes-bsp/pcmciautils/pcmciautils.inc b/meta/recipes-bsp/pcmciautils/pcmciautils.inc
index 04056e39c6..9d1c55bbad 100644
--- a/meta/recipes-bsp/pcmciautils/pcmciautils.inc
+++ b/meta/recipes-bsp/pcmciautils/pcmciautils.inc
@@ -23,7 +23,6 @@ LD = "${CC}"
CFLAGS =+ "-I${S}/src"
CFLAGS =+ "-DPCMCIAUTILS_VERSION=\\"${PV}\\""
-PARALLEL_MAKE = ""
EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs' 'LEX=flex'"
do_install () {
diff --git a/meta/recipes-bsp/pcmciautils/pcmciautils_018.bb b/meta/recipes-bsp/pcmciautils/pcmciautils_018.bb
index 50629b4b14..fc76c44626 100644
--- a/meta/recipes-bsp/pcmciautils/pcmciautils_018.bb
+++ b/meta/recipes-bsp/pcmciautils/pcmciautils_018.bb
@@ -1,6 +1,8 @@
require pcmciautils.inc
-SRC_URI += "file://makefile_fix.patch"
+SRC_URI += "file://makefile_fix.patch \
+ file://Makefile-fix-for-parallel-build.patch \
+"
SRC_URI[md5sum] = "5d85669b3440baa4532363da6caaf1b4"
SRC_URI[sha256sum] = "79e6ae441278e178c07501d492394ed2c0326fdb66894f6d040ec811b0dc8ed5"