aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-06-29 14:31:00 +0000
committerRichard Purdie <richard@openedhand.com>2007-06-29 14:31:00 +0000
commiteabfa35d7ce40d5eb9c0f74e9ef3db400c0c696d (patch)
tree2f09f6c743ecc803f0f29f9fc1c3c5984059e82e
parent320682b71e93e666dd5255ee3114e42096c5f692 (diff)
downloadopenembedded-core-contrib-eabfa35d7ce40d5eb9c0f74e9ef3db400c0c696d.tar.gz
Rewrite IMAGE_FEATURES tools options (people may be to update their local.conf), split into debug and profiling and add more profiling tools.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2063 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--build/conf/local.conf.sample27
-rw-r--r--meta/classes/poky-image.bbclass22
-rw-r--r--meta/packages/tasks/task-poky.bb54
3 files changed, 63 insertions, 40 deletions
diff --git a/build/conf/local.conf.sample b/build/conf/local.conf.sample
index 92f49097b7..3c22e0a2f8 100644
--- a/build/conf/local.conf.sample
+++ b/build/conf/local.conf.sample
@@ -30,19 +30,20 @@ DISTRO ?= "poky"
# IMAGE_FEATURES configuration of the generated images
# (Some of these are automatically added to certain image types)
-# "dev-pkgs" - add -dev packages for all installed packages
-# (useful if you want to develop against libs in the image)
-# "dbg-pkgs" - add -dbg packages for all installed packages
-# (adds symbol information for debugging/profiling)
-# "apps-core" - core applications
-# "apps-pda" - add PDA application suite (contacts, dates, etc.)
-# "dev-tools" - add development tools (gcc, make, pkgconfig etc.)
-# "dbg-tools" - add debugging tools (gdb, strace, oprofile, etc.)
-# "test-tools" - add useful testing tools (ts_print, aplay, arecord etc.)
-# "debug-tweaks" - make an image for suitable of development
-# e.g. ssh root access has a blank password
-
-IMAGE_FEATURES = "dbg-tools test-tools debug-tweaks"
+# "dbg-pkgs" - add -dbg packages for all installed packages
+# (adds symbol information for debugging/profiling)
+# "dev-pkgs" - add -dev packages for all installed packages
+# (useful if you want to develop against libs in the image)
+# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
+# "tools-debug" - add debugging tools (gdb, strace)
+# "tools-profile" - add profiling tools (oprofile, exmap, lttng valgrind (x86 only))
+# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
+# "debug-tweaks" - make an image for suitable of development
+# e.g. ssh root access has a blank password
+# There are other application targets too, see meta/classes/poky-image.bbclass
+# and meta/packages/tasks/task-poky.bb for more details.
+
+IMAGE_FEATURES = "tools-dbg tools-profile tools-testapps debug-tweaks"
# A list of packaging systems used in generated images
# The first package type listed will be used for rootfs generation
diff --git a/meta/classes/poky-image.bbclass b/meta/classes/poky-image.bbclass
index aaeaee7ea6..1e868a76fb 100644
--- a/meta/classes/poky-image.bbclass
+++ b/meta/classes/poky-image.bbclass
@@ -51,17 +51,21 @@ DISTRO_TASKS += '\
${@base_contains("IMAGE_FEATURES", ["apps-x11-pimlico", "dbg-pkgs"], "task-poky-apps-x11-pimlico-dbg", "",d)} \
${@base_contains("IMAGE_FEATURES", ["apps-x11-pimlico", "dev-pkgs"], "task-poky-apps-x11-pimlico-dev", "",d)} \
\
- ${@base_contains("IMAGE_FEATURES", "dev-tools", "task-poky-sdk", "",d)} \
- ${@base_contains("IMAGE_FEATURES", ["dev-tools", "dbg-pkgs"], "task-poky-sdk-dbg", "",d)} \
- ${@base_contains("IMAGE_FEATURES", ["dev-tools", "dev-pkgs"], "task-poky-sdk-dev", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", "tools-debug", "task-poky-tools-debug", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", ["tools-debug", "dbg-pkgs"], "task-poky-tools-debug-dbg", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", ["tools-debug", "dev-pkgs"], "task-poky-tools-debug-dev", "",d)} \
\
- ${@base_contains("IMAGE_FEATURES", "dbg-tools", "task-poky-devtools", "",d)} \
- ${@base_contains("IMAGE_FEATURES", ["dbg-tools", "dbg-pkgs"], "task-poky-devtools-dbg", "",d)} \
- ${@base_contains("IMAGE_FEATURES", ["dbg-tools", "dev-pkgs"], "task-poky-devtools-dev", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", "tools-profile", "task-poky-tools-profile", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", ["tools-profile", "dbg-pkgs"], "task-poky-tools-profile-dbg", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", ["tools-profile", "dev-pkgs"], "task-poky-tools-profile-dev", "",d)} \
\
- ${@base_contains("IMAGE_FEATURES", "test-tools", "task-poky-testapps", "",d)} \
- ${@base_contains("IMAGE_FEATURES", ["test-tools", "dbg-pkgs"], "task-poky-testapps-dbg", "",d)} \
- ${@base_contains("IMAGE_FEATURES", ["test-tools", "dev-pkgs"], "task-poky-testapps-dev", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", "tools-testapps", "task-poky-tools-testapps", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", ["tools-testapps", "dbg-pkgs"], "task-poky-testapps-dbg", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", ["tools-testapps", "dev-pkgs"], "task-poky-testapps-dev", "",d)} \
+ \
+ ${@base_contains("IMAGE_FEATURES", "tools-sdk", "task-poky-sdk", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", ["tools-sdk", "dbg-pkgs"], "task-poky-sdk-dbg", "",d)} \
+ ${@base_contains("IMAGE_FEATURES", ["tools-sdk", "dev-pkgs"], "task-poky-sdk-dev", "",d)} \
\
${@base_contains("IMAGE_FEATURES", "nfs-server", "task-poky-nfs-server", "",d)} \
${@base_contains("IMAGE_FEATURES", ["nfs-server", "dbg-pkgs"], "task-poky-nfs-server-dbg", "",d)} \
diff --git a/meta/packages/tasks/task-poky.bb b/meta/packages/tasks/task-poky.bb
index f965e2ff74..a6ef9cfefb 100644
--- a/meta/packages/tasks/task-poky.bb
+++ b/meta/packages/tasks/task-poky.bb
@@ -3,7 +3,7 @@
#
DESCRIPTION = "Tasks for OpenedHand Poky"
-PR = "r4"
+PR = "r5"
PACKAGES = "\
task-poky-apps-console \
@@ -24,12 +24,15 @@ PACKAGES = "\
task-poky-x11-sato \
task-poky-x11-sato-dbg \
task-poky-x11-sato-dev \
- task-poky-devtools \
- task-poky-devtools-dbg \
- task-poky-devtools-dev \
- task-poky-testapps \
- task-poky-testapps-dbg \
- task-poky-testapps-dev \
+ task-poky-tools-debug \
+ task-poky-tools-debug-dbg \
+ task-poky-tools-debug-dev \
+ task-poky-tools-profile \
+ task-poky-tools-profile-dbg \
+ task-poky-tools-profile-dev \
+ task-poky-tools-testapps \
+ task-poky-tools-testapps-dbg \
+ task-poky-tools-testapps-dev \
task-poky-nfs-server \
task-poky-nfs-server-dbg \
task-poky-nfs-server-dev \
@@ -41,12 +44,14 @@ XSERVER ?= "xserver-kdrive-fbdev"
ALLOW_EMPTY = "1"
+
RDEPENDS_task-poky-apps-console = "\
avahi-daemon \
dropbear \
portmap \
psplash"
+
RDEPENDS_task-poky-x11-base = "\
matchbox-common \
matchbox-wm \
@@ -64,23 +69,25 @@ RDEPENDS_task-poky-x11-base = "\
xset \
xrandr"
+
RDEPENDS_task-poky-apps-x11-core = "\
leafpad \
pcmanfm \
rxvt-unicode \
- screenshot \
- "
+ screenshot"
+
RDEPENDS_task-poky-apps-x11-games = "\
puzzles"
+
RDEPENDS_task-poky-apps-x11-pimlico = "\
eds-dbus \
contacts \
dates \
tasks \
- web \
- "
+ web"
+
RDEPENDS_task-poky-x11-sato = "\
matchbox-desktop \
@@ -95,18 +102,27 @@ RDEPENDS_task-poky-x11-sato = "\
settings-daemon \
gtk-sato-engine"
-RDEPENDS_task-poky-devtools = "\
+
+RDEPENDS_task-poky-tools-debug = "\
+ gdb \
+ strace"
+
+
+RDEPENDS_task-poky-tools-profile = "\
+ exmap-console \
+ exmap-server \
oprofile \
oprofileui-server \
- gdb \
- strace \
- less \
+ lttng-control \
lttng-viewer"
-RRECOMMENDS_task-poky-devtools = "\
+RDEPENDS_task-poky-tools-profile_qemux86 += "valgrind"
+
+RRECOMMENDS_task-poky-tools-profile = "\
kernel-module-oprofile"
-RDEPENDS_task-poky-testapps = "\
+
+RDEPENDS_task-poky-tools-testapps = "\
tslib-calibrate \
tslib-tests \
lrzsz \
@@ -114,7 +130,9 @@ RDEPENDS_task-poky-testapps = "\
alsa-utils-aplay \
owl-video-widget \
gst-meta-video \
- gst-meta-audio"
+ gst-meta-audio \
+ xvideo-tests"
+
RDEPENDS_task-poky-nfs-server = "\
nfs-utils"