aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-02-05 17:27:12 +0000
committerRichard Purdie <richard@openedhand.com>2008-02-05 17:27:12 +0000
commit48f8cda2c3248d57e6661092a22c3e335b6355d0 (patch)
tree786deece04d7fae473b103806a7b4d689aa14ef7
parent8f12b466e568b3f226720a54991a667203a351e4 (diff)
downloadopenembedded-core-contrib-48f8cda2c3248d57e6661092a22c3e335b6355d0.tar.gz
Rename gcc-native3 -> gcc3-native for consistency and update sanity.bbclass to account for gcc3 changes
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3670 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--build/conf/local.conf.sample2
-rw-r--r--meta/classes/sanity.bbclass7
-rw-r--r--meta/packages/gcc/gcc-native_3.4.4.bb2
-rw-r--r--meta/packages/qemu/qemu-native.inc2
4 files changed, 8 insertions, 5 deletions
diff --git a/build/conf/local.conf.sample b/build/conf/local.conf.sample
index 149cd81abf..122a6f720a 100644
--- a/build/conf/local.conf.sample
+++ b/build/conf/local.conf.sample
@@ -94,7 +94,7 @@ TMPDIR = "${OEROOT}/build/tmp"
# Comment this out if you don't have a 3.x gcc version available and wish
# poky to build one for you. The 3.x gcc is required to build qemu-native.
-ASSUME_PROVIDED += "gcc-native3"
+ASSUME_PROVIDED += "gcc3-native"
# Uncomment these two if you want BitBake to build images useful for debugging.
# DEBUG_BUILD = "1"
diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 85a38ba285..46bc7c66b6 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -85,12 +85,15 @@ def check_sanity(e):
required_utilities = "patch help2man diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk md5sum"
# qemu-native needs gcc 3.x
- if "qemu-native" not in assume_provided:
+ if "qemu-native" not in assume_provided and "gcc3-native" in assume_provided:
gcc_version = commands.getoutput("${BUILD_PREFIX}gcc --version | head -n 1 | cut -f 3 -d ' '")
if not check_gcc3(e.data) and gcc_version[0] != '3':
+ messages = messages + "gcc3-native was in ASSUME_PROVIDED but the gcc-3.x binary can't be found in PATH"
missing = missing + "gcc-3.x (needed for qemu-native),"
- else:
+
+ if "qemu-native" in assume_provided:
+ messages = messages + "qemu-native was in ASSUME_PROVIDED but the QEMU binaries can't be found in PATH"
required_utilities = required_utilities + " qemu-arm"
for util in required_utilities.split():
diff --git a/meta/packages/gcc/gcc-native_3.4.4.bb b/meta/packages/gcc/gcc-native_3.4.4.bb
index eb1fb5716e..d70a4f5464 100644
--- a/meta/packages/gcc/gcc-native_3.4.4.bb
+++ b/meta/packages/gcc/gcc-native_3.4.4.bb
@@ -1,3 +1,3 @@
require gcc_${PV}.bb
require gcc-native.inc
-PROVIDES += "gcc-native3" \ No newline at end of file
+PROVIDES += "gcc3-native"
diff --git a/meta/packages/qemu/qemu-native.inc b/meta/packages/qemu/qemu-native.inc
index db405c940d..8a25383c59 100644
--- a/meta/packages/qemu/qemu-native.inc
+++ b/meta/packages/qemu/qemu-native.inc
@@ -1,5 +1,5 @@
inherit native
-DEPENDS = "zlib-native gcc-native3"
+DEPENDS = "zlib-native gcc3-native"
require qemu-gcc3-check.inc