aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-opie/opie-currconv/opie-currconv.inc18
-rw-r--r--recipes-opie/opie-currconv/opie-currconv_git.bb7
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes-opie/opie-currconv/opie-currconv.inc b/recipes-opie/opie-currconv/opie-currconv.inc
new file mode 100644
index 0000000..6a08ff3
--- /dev/null
+++ b/recipes-opie/opie-currconv/opie-currconv.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Currency converter for Opie"
+SECTION = "opie/applications"
+LICENSE = "GPLv2"
+# FIXME stopgap until split archives have license files included
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+APPNAME = "currconv"
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
+RDEPENDS_${PN} += "wget"
+
diff --git a/recipes-opie/opie-currconv/opie-currconv_git.bb b/recipes-opie/opie-currconv/opie-currconv_git.bb
new file mode 100644
index 0000000..f95e7d6
--- /dev/null
+++ b/recipes-opie/opie-currconv/opie-currconv_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/tools/currconv \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"