aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/obexpush/files/fix-open.patch18
-rw-r--r--recipes-support/obexpush/obexpush_1.0.0.bb1
2 files changed, 19 insertions, 0 deletions
diff --git a/recipes-support/obexpush/files/fix-open.patch b/recipes-support/obexpush/files/fix-open.patch
new file mode 100644
index 0000000..1280daf
--- /dev/null
+++ b/recipes-support/obexpush/files/fix-open.patch
@@ -0,0 +1,18 @@
+Index: obexpush/opd/main.c
+===================================================================
+--- obexpush.orig/opd/main.c
++++ obexpush/opd/main.c
+@@ -562,11 +562,11 @@ int main(int argc, char **argv,char *env
+ dup2(fd, 0);
+ close(fd);
+
+- fd = open("_opd_msgs.txt", O_RDWR | O_CREAT);
++ fd = open("_opd_msgs.txt", O_RDWR | O_CREAT, S_IRUSR | S_IWUSR);
+ dup2(fd, 1);
+ close(fd);
+
+- fd = open("_opd_errs.txt", O_RDWR | O_CREAT);
++ fd = open("_opd_errs.txt", O_RDWR | O_CREAT, S_IRUSR | S_IWUSR);
+ dup2(fd, 2);
+ close(fd);
+
diff --git a/recipes-support/obexpush/obexpush_1.0.0.bb b/recipes-support/obexpush/obexpush_1.0.0.bb
index 5018728..0cb18cd 100644
--- a/recipes-support/obexpush/obexpush_1.0.0.bb
+++ b/recipes-support/obexpush/obexpush_1.0.0.bb
@@ -8,6 +8,7 @@ PR = "r7"
SRC_URI = "http://www.caside.lancs.ac.uk/bt/obexpush.tar.gz \
file://add-obextool.patch \
+ file://fix-open.patch \
file://init \
file://opd_args"
S = "${WORKDIR}/obexpush"