aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-opie/images/opie-image-connman.bb21
-rw-r--r--recipes-opie/tasks/task-connman.bb15
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-opie/images/opie-image-connman.bb b/recipes-opie/images/opie-image-connman.bb
new file mode 100644
index 0000000..d13a6a7
--- /dev/null
+++ b/recipes-opie/images/opie-image-connman.bb
@@ -0,0 +1,21 @@
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+IMAGE_LINGUAS = ""
+
+DEPENDS = "task-base task-opie"
+
+IMAGE_FEATURES = "ssh-server-dropbear"
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE} task-opie-base task-opie-base-applets \
+ task-opie-base-inputmethods task-opie-base-apps \
+ task-opie-base-settings task-opie-base-decorations \
+ task-opie-base-styles task-opie-base-pim \
+ task-opie-extra-settings \
+ task-opie-connman \
+ ${@base_contains("COMBINED_FEATURES", "bluetooth", "task-opie-bluetooth", "",d)} \
+ ${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
+ ${ANGSTROM_EXTRA_INSTALL} "
+
+inherit core-image
+
diff --git a/recipes-opie/tasks/task-connman.bb b/recipes-opie/tasks/task-connman.bb
new file mode 100644
index 0000000..6c70ba1
--- /dev/null
+++ b/recipes-opie/tasks/task-connman.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Tasks for Opie ConnMan settings"
+LICENSE = "MIT"
+
+PR = "r0"
+
+inherit task
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+RDEPENDS_${PN} = "opie-connmansettings opie-connmanapplet \
+ connman-plugin-ethernet \
+ ${@base_contains('DISTRO_FEATURES', 'wifi', 'connman-plugin-wifi', '',d)} \
+ ${@base_contains('DISTRO_FEATURES', 'bluetooth', 'connman-plugin-bluetooth', '',d)} \
+ "
+