aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-21 20:40:58 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-21 20:51:42 +0100
commite4b83493c9509adaa286ebc6a50136cd3d85eb15 (patch)
treeee4e840c414b2b73d972117c67c69c28463a2fdc /recipes-qtopia
parentc91505f3c9c7ec12d538f8c640600e2aa7b99ce9 (diff)
downloadmeta-opie-e4b83493c9509adaa286ebc6a50136cd3d85eb15.tar.gz
zbedic: fix compilation on newer systems
Add include for stdlib.h which seems to no longer be included automatically on modern systems. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia')
-rw-r--r--recipes-qtopia/zbedic/zbedic/stdlib_h.patch14
-rw-r--r--recipes-qtopia/zbedic/zbedic_1.2.bb5
2 files changed, 17 insertions, 2 deletions
diff --git a/recipes-qtopia/zbedic/zbedic/stdlib_h.patch b/recipes-qtopia/zbedic/zbedic/stdlib_h.patch
new file mode 100644
index 0000000..e02fcca
--- /dev/null
+++ b/recipes-qtopia/zbedic/zbedic/stdlib_h.patch
@@ -0,0 +1,14 @@
+Include stdlib.h for the abs() function.
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+--- zbedic-1.2.orig/src/settings.cpp
++++ zbedic-1.2/src/settings.cpp
+@@ -23,6 +23,7 @@
+ ****************************************************************************/
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #include <qlabel.h>
+ #include <qhbox.h>
diff --git a/recipes-qtopia/zbedic/zbedic_1.2.bb b/recipes-qtopia/zbedic/zbedic_1.2.bb
index 82ded79..4e63a91 100644
--- a/recipes-qtopia/zbedic/zbedic_1.2.bb
+++ b/recipes-qtopia/zbedic/zbedic_1.2.bb
@@ -6,11 +6,12 @@ LICENSE = "GPL"
DEPENDS = "libbedic"
APPTYPE = "binary"
APPDESKTOP = "${WORKDIR}/misc"
-PR = "r3"
+PR = "r4"
SRC_URI = "${SOURCEFORGE_MIRROR}/bedic/zbedic_${PV}-2.tgz;subdir=${BPN}-${PV} \
file://opie-icons.patch \
- file://qtopia17.patch"
+ file://qtopia17.patch \
+ file://stdlib_h.patch"
inherit opie
export OE_QMAKE_LINK="${CXX}"