aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/zsafe
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/zsafe
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/zsafe')
-rw-r--r--recipes-qtopia/zsafe/zsafe_2.1.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-qtopia/zsafe/zsafe_2.1.3.bb b/recipes-qtopia/zsafe/zsafe_2.1.3.bb
new file mode 100644
index 0000000..f417edb
--- /dev/null
+++ b/recipes-qtopia/zsafe/zsafe_2.1.3.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Password manager"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RCONFLICTS_${PN} = "opie-zsafe"
+APPNAME = "zsafe"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+SRC_URI = "http://z-soft.z-portal.info/zsafe/zsafe_2.1.3.tgz"
+S = "${WORKDIR}"
+PR = "r1"
+
+inherit opie
+
+QMAKE_PROFILES = "zsafe.pro"
+
+export OE_QMAKE_LINK="${CXX}"
+
+#FILES bin/zsafe apps/Applications/zsafe.desktop pics/zsafe/zsafe.png
+
+FILES_zsafe = "zsafe"
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.xpm ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/zsafe.png ${D}${palmtopdir}/pics/
+}
+
+SRC_URI[md5sum] = "5e4e10a67de603b04b752ed00311455d"
+SRC_URI[sha256sum] = "0937b15ca5dcd6f49adff04096610cee1f70197e17d461aefa98ed52e5ea0b72"