aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/prboom/prboom_2.5.0.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/prboom/prboom_2.5.0.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/prboom/prboom_2.5.0.bb')
-rw-r--r--recipes-qtopia/prboom/prboom_2.5.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-qtopia/prboom/prboom_2.5.0.bb b/recipes-qtopia/prboom/prboom_2.5.0.bb
new file mode 100644
index 0000000..ef6bb57
--- /dev/null
+++ b/recipes-qtopia/prboom/prboom_2.5.0.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A Doom Clone based on SDL"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libsdl-mixer libsdl-net"
+LICENSE = "GPL"
+
+PR = "r4"
+RRECOMMENDS_${PN} = "freedoom"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/prboom/prboom-${PV}.tar.gz \
+ file://gnu_source_for_sched_h.patch \
+ "
+
+inherit autotools
+
+EXTRA_OECONF = " --disable-gl --disable-cpu-opt --without-x --disable-sdltest \
+ SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config"
+
+do_install() {
+ install -d ${D}${bindir} \
+ ${D}${datadir}/games/doom
+
+ install -m 0755 src/prboom ${D}${bindir}/prboom
+ install -m 0644 data/prboom.wad ${D}${datadir}/games/doom/
+}
+
+FILES_${PN} += "${datadir}/games/doom/prboom.wad"
+
+SRC_URI[md5sum] = "a8a15f61fa2626ab98051ab2703378c4"
+SRC_URI[sha256sum] = "226c1c470f8cc983327536404f405a1d026cf0a5188c694a1243cc8630014bae"