aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/prboom/prboom_2.3.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/prboom/prboom_2.3.1.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/prboom/prboom_2.3.1.bb')
-rw-r--r--recipes-qtopia/prboom/prboom_2.3.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-qtopia/prboom/prboom_2.3.1.bb b/recipes-qtopia/prboom/prboom_2.3.1.bb
new file mode 100644
index 0000000..f4a61d9
--- /dev/null
+++ b/recipes-qtopia/prboom/prboom_2.3.1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "A Doom Clone based on SDL"
+SECTION = "opie/games"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe libsdl-mixer libsdl-net"
+LICENSE = "GPL"
+
+# This version can be started w/ -height 240 but it
+# a) doesn't load doom1.wad (crash)
+# b) crahes a few seconds after starting w/ doom2.wad
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/prboom/prboom-${PV}.tar.gz \
+ file://prboom.png \
+ file://prboom.desktop"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-x --disable-sdltest"
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Games \
+ ${D}${palmtopdir}/pics \
+ ${D}${datadir}/games/doom
+ install -m 0755 src/prboom ${D}${palmtopdir}/bin/prboom
+ install -m 0644 data/prboom.wad ${D}${datadir}/games/doom/
+ install -m 0644 ${WORKDIR}/prboom.png ${D}${palmtopdir}/pics/prboom.png
+ install -m 0644 ${WORKDIR}/prboom.desktop ${D}${palmtopdir}/apps/Games/prboom.desktop
+}
+
+FILES_${PN} = "${palmtopdir} ${datadir}/games/doom/prboom.wad"
+
+SRC_URI[md5sum] = "c53231604fe6cf7352e73911ad44c90d"
+SRC_URI[sha256sum] = "6465b37ef96c04d95dcb887f907da1af43a33783e8c5e80527bceda97202876a"