aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/irk
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/irk
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/irk')
-rw-r--r--recipes-qtopia/irk/files/install-default-conf.patch18
-rw-r--r--recipes-qtopia/irk/irk-belkin_0.11.bb12
-rw-r--r--recipes-qtopia/irk/irk-targus_0.11.0.bb14
-rw-r--r--recipes-qtopia/irk/irk.inc24
4 files changed, 68 insertions, 0 deletions
diff --git a/recipes-qtopia/irk/files/install-default-conf.patch b/recipes-qtopia/irk/files/install-default-conf.patch
new file mode 100644
index 0000000..a55992a
--- /dev/null
+++ b/recipes-qtopia/irk/files/install-default-conf.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- irk/irk.cpp~install-default-config
++++ irk/irk.cpp
+@@ -470,6 +470,10 @@
+
+ void CGIRK::readConfig()
+ {
++ // check if the config is there, if not copy it from default location
++ // FIXME: Do it properly once confirmed that it works :D
++ ::system( "if [ ! -e \"$HOME/Settings/IRK.conf\" ]; then cat $OPIEDIR/etc/skel/IRK.conf >$HOME/Settings/IRK.conf; fi" );
++
+ // clear the keyboard list ready for the new one to be loaded in
+ m_keyboardList.clear();
+ #if !POCKETOP_BUILD
diff --git a/recipes-qtopia/irk/irk-belkin_0.11.bb b/recipes-qtopia/irk/irk-belkin_0.11.bb
new file mode 100644
index 0000000..3de38f3
--- /dev/null
+++ b/recipes-qtopia/irk/irk-belkin_0.11.bb
@@ -0,0 +1,12 @@
+require irk.inc
+
+DESCRIPTION += "(version with Belkin support)"
+RCONFLICTS_${PN} = "irk-targus"
+RREPLACES_${PN} = "irk-targus"
+PR = "r4"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/irk-current.tgz \
+ file://install-default-conf.patch"
+
+SRC_URI[md5sum] = "a77eaea6930b9af5bbcd59bf9f8859c8"
+SRC_URI[sha256sum] = "942240421710da8a04fa6c7071f50f0737ab7198e31c1d96f1e0b73330e0d066"
diff --git a/recipes-qtopia/irk/irk-targus_0.11.0.bb b/recipes-qtopia/irk/irk-targus_0.11.0.bb
new file mode 100644
index 0000000..252b2c9
--- /dev/null
+++ b/recipes-qtopia/irk/irk-targus_0.11.0.bb
@@ -0,0 +1,14 @@
+require irk.inc
+PR = "r3"
+
+DESCRIPTION += "(version with Targus support)"
+HOMEPAGE = "http://angela1.data-uncertain.co.uk/~zaurus/irk.php"
+
+RCONFLICTS_${PN} = "irk-belkin"
+RREPLACES_${PN} = "irk-belkin"
+
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/irk-${PV}.tgz \
+ file://install-default-conf.patch"
+
+SRC_URI[md5sum] = "5b39a7fb06fd24edfb543a3a0130065c"
+SRC_URI[sha256sum] = "5eeba81a5e5163e0b0b92b5e5aaf91c07b412a743a98f59975c75d28c133a85f"
diff --git a/recipes-qtopia/irk/irk.inc b/recipes-qtopia/irk/irk.inc
new file mode 100644
index 0000000..b00583c
--- /dev/null
+++ b/recipes-qtopia/irk/irk.inc
@@ -0,0 +1,24 @@
+DESCRIPTION = "IRK provides a Qtopia/Opie Input Method plugin that allows you to use external infrared keyboards with the Zaurus."
+SECTION = "opie/inputmethods"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://angela1.data-uncertain.co.uk/~zaurus/irk.php"
+DEPENDS = "lirc"
+
+S = "${WORKDIR}/irk"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += "CONFIG-=qtopia INCLUDEPATH+=${STAGING_INCDIR}/lirc"
+
+do_install() {
+ install -d ${D}${sysconfdir}/
+ install -d ${D}${palmtopdir}/etc/skel/
+ install -d ${D}${palmtopdir}/plugins/inputmethods/
+
+ install -m 0644 chicony.conf ${D}${sysconfdir}/lircd.conf
+ install -m 0644 IRK.conf ${D}${palmtopdir}/etc/skel/
+ oe_libinstall -so libirk ${D}${palmtopdir}/plugins/inputmethods
+}
+
+FILES_${PN} += "${sysconfdir}"