aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/packagegroups/packagegroup-opie-all.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-05 09:53:14 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-09 16:24:51 +0100
commit94d151708f4ff6946bf80cb11c6b740871a251c7 (patch)
treec20d7391a3a88236c0d6a665dec2a9104c539ac4 /recipes-opie/packagegroups/packagegroup-opie-all.bb
parent235eb64b210937e359398ddbaf1ea495e58d5c9f (diff)
downloadmeta-opie-94d151708f4ff6946bf80cb11c6b740871a251c7.tar.gz
packagegroup-*: add RPROVIDES/RREPLACES/RCONFLICTS
Allow upgrades from previous task packages. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/packagegroups/packagegroup-opie-all.bb')
-rw-r--r--recipes-opie/packagegroups/packagegroup-opie-all.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/recipes-opie/packagegroups/packagegroup-opie-all.bb b/recipes-opie/packagegroups/packagegroup-opie-all.bb
index 17541da..144642d 100644
--- a/recipes-opie/packagegroups/packagegroup-opie-all.bb
+++ b/recipes-opie/packagegroups/packagegroup-opie-all.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Tasks for OPIE stuff"
SECTION = "opie/base"
LICENSE = "MIT"
-PR = "r3"
+PR = "r4"
inherit packagegroup
@@ -68,3 +68,12 @@ RDEPENDS_packagegroup-opie-todayplugins = "opie-today-addressbookplugin opie-tod
RDEPENDS_packagegroup-opie-wlan = "wireless-tools opie-wellenreiter opie-networksettings-wlanplugin"
+python __anonymous() {
+ # For backwards compatibility after rename
+ packages = d.getVar("PACKAGES", True).split()
+ for pkg in packages:
+ d.appendVar("RPROVIDES_%s" % pkg, pkg.replace("packagegroup-", "task-"))
+ d.appendVar("RREPLACES_%s" % pkg, pkg.replace("packagegroup-", "task-"))
+ d.appendVar("RCONFLICTS_%s" % pkg, pkg.replace("packagegroup-", "task-"))
+}
+