aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-sounds
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-sounds
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-sounds')
-rw-r--r--recipes-opie/opie-sounds/opie-sounds.inc18
-rw-r--r--recipes-opie/opie-sounds/opie-sounds_1.2.5.bb7
-rw-r--r--recipes-opie/opie-sounds/opie-sounds_cvs.bb7
3 files changed, 32 insertions, 0 deletions
diff --git a/recipes-opie/opie-sounds/opie-sounds.inc b/recipes-opie/opie-sounds/opie-sounds.inc
new file mode 100644
index 0000000..aa39e6e
--- /dev/null
+++ b/recipes-opie/opie-sounds/opie-sounds.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Common Opie Sounds"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/sounds"
+
+SOUNDS = "alarm touchsound keysound"
+
+do_install() {
+ install -d ${D}${palmtopdir}/sounds/
+ for i in ${SOUNDS}
+ do
+ install $i.wav ${D}${palmtopdir}/sounds/$i.wav
+ done
+}
+
+FILES_${PN} = "${palmtopdir}"
diff --git a/recipes-opie/opie-sounds/opie-sounds_1.2.5.bb b/recipes-opie/opie-sounds/opie-sounds_1.2.5.bb
new file mode 100644
index 0000000..ad38275
--- /dev/null
+++ b/recipes-opie/opie-sounds/opie-sounds_1.2.5.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_sounds.tar.bz2;name=split_sounds"
+SRC_URI[split_sounds.md5sum] = "b0f2bee8c158f54162e5e74d4d9594df"
+SRC_URI[split_sounds.sha256sum] = "55441675b28209cb2e34ffc0875c6d47aee27bd65dbdb40a223e5fa05c5a7c06"
diff --git a/recipes-opie/opie-sounds/opie-sounds_cvs.bb b/recipes-opie/opie-sounds/opie-sounds_cvs.bb
new file mode 100644
index 0000000..77efe49
--- /dev/null
+++ b/recipes-opie/opie-sounds/opie-sounds_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
+PV = "${OPIE_GIT_PV}"
+PR = "r1"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=sounds"