aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-sh-snes
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-sh-snes
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-sh-snes')
-rw-r--r--recipes-opie/opie-sh-snes/files/opie-sh-snes.sh50
-rw-r--r--recipes-opie/opie-sh-snes/files/snes.desktop6
-rw-r--r--recipes-opie/opie-sh-snes/files/snes.pngbin0 -> 2308 bytes
-rw-r--r--recipes-opie/opie-sh-snes/opie-sh-snes.inc27
-rw-r--r--recipes-opie/opie-sh-snes/opie-sh-snes_0.2.bb28
-rw-r--r--recipes-opie/opie-sh-snes/opie-sh-snes_1.2.5.bb3
-rw-r--r--recipes-opie/opie-sh-snes/opie-sh-snes_cvs.bb4
7 files changed, 118 insertions, 0 deletions
diff --git a/recipes-opie/opie-sh-snes/files/opie-sh-snes.sh b/recipes-opie/opie-sh-snes/files/opie-sh-snes.sh
new file mode 100644
index 0000000..0d5c3e0
--- /dev/null
+++ b/recipes-opie/opie-sh-snes/files/opie-sh-snes.sh
@@ -0,0 +1,50 @@
+#!/bin/sh
+#Path to your Roms if you want to disable the menu
+#LOCATION=/mnt/card/games/snes
+
+# Give a default
+if test -e /root/Settings/opie-sh-snes.conf
+then
+ LOCATION="`cat /root/Settings/opie-sh-snes.conf`"
+else
+ echo "/mnt/card/games/snes" > /root/Settings/opie-sh-snes.conf
+ #Enable Menu Rom Finder
+ LOCATION="` opie-sh -i -t "Path to Roms" -g -E -l -F /root/Settings/opie-sh-snes.conf `"
+ ! test -z "$LOCATION" && echo $LOCATION > /root/Settings/opie-sh-snes.conf
+fi
+
+echo "LOCATION = [$LOCATION]"
+if [ "$LOCATION" = "" ]; then exit; fi
+
+
+#Load a game from your list
+ROM=` cd "$LOCATION" ; ls -1 *.zip \
+ | opie-sh -i -l -t "Snes9x" -F -g `
+if [ "$ROM" = "" ]; then exit; fi
+
+echo "ROM = [$ROM]"
+
+#Enable Sound Button
+setsound () {
+ opie-sh -m -t "Sound" \
+ -M "Do you want sound?" \
+ -g -0 Yes -1 No
+RETURNCODE=$?
+
+case $RETURNCODE in
+ 0) SOUND="-sound" ;;
+ 1) SOUND="-nosound" ;;
+esac
+
+echo "SOUND = [$SOUND] / RC = [$?]"
+}
+
+
+setsound
+
+
+
+if [ "$SOUND" = "" ]; then exit; fi
+
+
+snes9x $SOUND "$LOCATION/$ROM"
diff --git a/recipes-opie/opie-sh-snes/files/snes.desktop b/recipes-opie/opie-sh-snes/files/snes.desktop
new file mode 100644
index 0000000..3139498
--- /dev/null
+++ b/recipes-opie/opie-sh-snes/files/snes.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Name=Snes9x
+Icon=snes
+Exec=opie-sh-snes.sh
+Comment=Displays a list of games for use with snes9x
+Type=Application
diff --git a/recipes-opie/opie-sh-snes/files/snes.png b/recipes-opie/opie-sh-snes/files/snes.png
new file mode 100644
index 0000000..2c0abfe
--- /dev/null
+++ b/recipes-opie/opie-sh-snes/files/snes.png
Binary files differ
diff --git a/recipes-opie/opie-sh-snes/opie-sh-snes.inc b/recipes-opie/opie-sh-snes/opie-sh-snes.inc
new file mode 100644
index 0000000..15a8ac0
--- /dev/null
+++ b/recipes-opie/opie-sh-snes/opie-sh-snes.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "Displays a list of available ROMs for use with snes9x."
+SECTION = "opie/shell"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+RDEPENDS_${PN} = "opie-sh"
+
+inherit opie
+
+FILES_${PN} = "/opt/QtPalmtop"
+
+SRC_URI = "file://snes.desktop \
+ file://snes.png \
+ file://opie-sh-snes.sh"
+
+
+do_install() {
+
+ for dir in apps apps/Games bin pics
+ do
+ install -d ${D}${palmtopdir}/$dir
+ done
+
+ install -m 755 ${WORKDIR}/opie-sh-snes.sh ${D}${palmtopdir}/bin
+ install -m 644 ${WORKDIR}/*.png ${D}${palmtopdir}/pics
+ install -m 644 ${WORKDIR}/*.desktop ${D}${palmtopdir}/apps/Games
+}
diff --git a/recipes-opie/opie-sh-snes/opie-sh-snes_0.2.bb b/recipes-opie/opie-sh-snes/opie-sh-snes_0.2.bb
new file mode 100644
index 0000000..5e709e4
--- /dev/null
+++ b/recipes-opie/opie-sh-snes/opie-sh-snes_0.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Displays a list of available ROMs for use with snes9x."
+SECTION = "opie/shell"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+RDEPENDS_${PN} = "opie-sh"
+
+
+PR = "r3"
+
+FILES_${PN} = "/opt/QtPalmtop"
+
+SRC_URI = "file://snes.desktop \
+ file://snes.png \
+ file://opie-sh-snes.sh"
+
+
+do_install() {
+
+ for dir in apps apps/Games bin pics
+ do
+ install -d ${D}${palmtopdir}/$dir
+ done
+
+ install -m 755 ${WORKDIR}/opie-sh-snes.sh ${D}${palmtopdir}/bin
+ install -m 644 ${WORKDIR}/*.png ${D}${palmtopdir}/pics
+ install -m 644 ${WORKDIR}/*.desktop ${D}${palmtopdir}/apps/Games
+}
diff --git a/recipes-opie/opie-sh-snes/opie-sh-snes_1.2.5.bb b/recipes-opie/opie-sh-snes/opie-sh-snes_1.2.5.bb
new file mode 100644
index 0000000..9a48668
--- /dev/null
+++ b/recipes-opie/opie-sh-snes/opie-sh-snes_1.2.5.bb
@@ -0,0 +1,3 @@
+require ${PN}.inc
+
+PR = "r0"
diff --git a/recipes-opie/opie-sh-snes/opie-sh-snes_cvs.bb b/recipes-opie/opie-sh-snes/opie-sh-snes_cvs.bb
new file mode 100644
index 0000000..7788d32
--- /dev/null
+++ b/recipes-opie/opie-sh-snes/opie-sh-snes_cvs.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r2"