aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/libopieobex
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/libopieobex
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/libopieobex')
-rw-r--r--recipes-opie/libopieobex/files/disable-bt-check.patch19
-rw-r--r--recipes-opie/libopieobex/libopieobex0.inc27
-rw-r--r--recipes-opie/libopieobex/libopieobex0_1.2.5.bb10
-rw-r--r--recipes-opie/libopieobex/libopieobex0_cvs.bb7
4 files changed, 63 insertions, 0 deletions
diff --git a/recipes-opie/libopieobex/files/disable-bt-check.patch b/recipes-opie/libopieobex/files/disable-bt-check.patch
new file mode 100644
index 0000000..067af14
--- /dev/null
+++ b/recipes-opie/libopieobex/files/disable-bt-check.patch
@@ -0,0 +1,19 @@
+--- obex/obex.pro 2007-07-20 23:44:06.000000000 +1200
++++ obex/obex.pro 2007-10-18 17:57:15.000000000 +1300
+@@ -13,12 +13,12 @@
+ include( $(OPIEDIR)/include.pro )
+ target.path = $$prefix/plugins/applets
+
+-#FIXME: These parameters are used if bluetooth is used
+-CONFTEST = $$system( echo $CONFIG_LIBOPIETOOTH )
+-contains( CONFTEST, y ){
++#FIXME: This test does not work under OE. Instead, just always enable bluetooth.
++#CONFTEST = $$system( echo $CONFIG_LIBOPIETOOTH )
++#contains( CONFTEST, y ){
+ HEADERS += btobex.h
+ SOURCES += btobex.cpp
+ INCLUDEPATH += $(OPIEDIR)/noncore/net/opietooth/lib
+ LIBS += -lopietooth1 -lbluetooth
+ DEFINES += BLUETOOTH
+-}
++#}
diff --git a/recipes-opie/libopieobex/libopieobex0.inc b/recipes-opie/libopieobex/libopieobex0.inc
new file mode 100644
index 0000000..87d0dd7
--- /dev/null
+++ b/recipes-opie/libopieobex/libopieobex0.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "IrDA obex support library"
+SECTION = "opie/libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "libopietooth1 opie-taskbar openobex-apps"
+RDEPENDS_${PN} = "openobex-apps"
+APPNAME = "obex"
+
+S = "${WORKDIR}/obex"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/opietooth"
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/ ${D}${palmtopdir}/plugins/obex/
+ install -m 0644 ${WORKDIR}/pics/backup/check.png ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+ oe_libinstall -so libopieobex ${D}${palmtopdir}/plugins/obex/
+}
+
+FILES_${PN} = "${palmtopdir}/plugins/obex/ ${palmtopdir}/pics/obex/"
+FILES_${PN}-dev = "${palmtopdir}/plugins/obex/lib*.so"
+FILES_${PN}-dbg = "${palmtopdir}/plugins/obex/.debug"
+
+
+
diff --git a/recipes-opie/libopieobex/libopieobex0_1.2.5.bb b/recipes-opie/libopieobex/libopieobex0_1.2.5.bb
new file mode 100644
index 0000000..43f0a9b
--- /dev/null
+++ b/recipes-opie/libopieobex/libopieobex0_1.2.5.bb
@@ -0,0 +1,10 @@
+require libopieobex0.inc
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_obex.tar.bz2;name=split_core_obex \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ file://disable-bt-check.patch"
+SRC_URI[split_core_obex.md5sum] = "9fff83489fa298d5fe0b698936eb6a8d"
+SRC_URI[split_core_obex.sha256sum] = "e92b9d37ef2c4de2f9264eaa4ee59a56fc710bf6cd0c22cdc117d855d5379c5a"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
diff --git a/recipes-opie/libopieobex/libopieobex0_cvs.bb b/recipes-opie/libopieobex/libopieobex0_cvs.bb
new file mode 100644
index 0000000..318bee6
--- /dev/null
+++ b/recipes-opie/libopieobex/libopieobex0_cvs.bb
@@ -0,0 +1,7 @@
+require libopieobex0.inc
+PV = "${OPIE_GIT_PV}"
+PR = "r8"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/obex \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ file://disable-bt-check.patch"