aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2011-12-13 20:24:40 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2011-12-13 20:24:40 +0400
commit2f67ac9db9d3fd5883c5e0d954f8cf30bd97170c (patch)
treeda248944bc8d5c34b4bce104d189755ea7ce9d1b
parent1b9a1e67b3311f95c7cd4c21e630372c8f444838 (diff)
downloadmeta-opie-2f67ac9db9d3fd5883c5e0d954f8cf30bd97170c.tar.gz
qmake: do also provide nativesdk variant
Opie SDK needs nativesdk version of qmake package. To achieve this, replace qmake-native with qmake recipe, which can be built both as virtclass-native and virtclass-nativesdk. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
-rw-r--r--recipes-qt/qmake/qmake_1.07a.bb (renamed from recipes-qt/qmake/qmake-native_1.07a.bb)8
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes-qt/qmake/qmake-native_1.07a.bb b/recipes-qt/qmake/qmake_1.07a.bb
index e4f0cd5..8bd57b2 100644
--- a/recipes-qt/qmake/qmake-native_1.07a.bb
+++ b/recipes-qt/qmake/qmake_1.07a.bb
@@ -13,10 +13,11 @@ S = "${WORKDIR}/${QTEVER}"
LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=629178675a7d49c9fa19dfe9f43ea256 \
file://README;beginline=1;endline=7;md5=a85582a7befb26735438461afd8559af"
-inherit autotools native
+inherit qmake_base
+BBCLASSEXTEND = "native nativesdk"
export QTDIR = "${S}"
-EXTRA_OEMAKE = "-e"
+EXTRA_OECONF += "-platform ${HOST_OS}-oe-g++"
do_configure() {
# Install the OE build templates
@@ -26,9 +27,6 @@ do_configure() {
install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf
ln -sf ../linux-g++/qplatformdefs.h ${S}/mkspecs/$template/qplatformdefs.h
done
- QMAKESPEC=
- PLATFORM=${HOST_OS}-oe-g++
- export PLATFORM
bbnote ./configure ${EXTRA_OECONF}
echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed"
}