aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-03 00:19:05 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-03 00:19:05 +0000
commit4618b40a6a7b2302faecc57906d677a9602c00b1 (patch)
tree97c6ddd274ac7970066aa837776e123238522ed4
parent46e9513f46b6d2b7a88025e97db4aeac190531d5 (diff)
downloadmeta-opie-4618b40a6a7b2302faecc57906d677a9602c00b1.tar.gz
Add recipes for connman settings/applet
These have just been added in the Opie master branch. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--recipes-opie/opie-connmanapplet/opie-connmanapplet.inc18
-rw-r--r--recipes-opie/opie-connmanapplet/opie-connmanapplet_git.bb7
-rw-r--r--recipes-opie/opie-connmansettings/opie-connmansettings.inc18
-rw-r--r--recipes-opie/opie-connmansettings/opie-connmansettings_git.bb7
4 files changed, 50 insertions, 0 deletions
diff --git a/recipes-opie/opie-connmanapplet/opie-connmanapplet.inc b/recipes-opie/opie-connmanapplet/opie-connmanapplet.inc
new file mode 100644
index 0000000..a737e29
--- /dev/null
+++ b/recipes-opie/opie-connmanapplet/opie-connmanapplet.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Opie Network Management Applet"
+SECTION = "opie/applets"
+LICENSE = "GPLv2"
+# FIXME stopgap until split archives have license files included
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+APPNAME = "connmanapplet"
+
+RDEPENDS_${PN} += "opie-connmansettings connman"
+
+S = "${WORKDIR}/applet"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/connmanapplet
+ install -m 0644 ${WORKDIR}/pics/connmanapplet/*.png ${D}${palmtopdir}/pics/connmanapplet
+}
+
diff --git a/recipes-opie/opie-connmanapplet/opie-connmanapplet_git.bb b/recipes-opie/opie-connmanapplet/opie-connmanapplet_git.bb
new file mode 100644
index 0000000..2394b3f
--- /dev/null
+++ b/recipes-opie/opie-connmanapplet/opie-connmanapplet_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r0"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/net/connman/applet \
+ ${OPIE_GIT};protocol=git;subpath=pics"
diff --git a/recipes-opie/opie-connmansettings/opie-connmansettings.inc b/recipes-opie/opie-connmansettings/opie-connmansettings.inc
new file mode 100644
index 0000000..53885c8
--- /dev/null
+++ b/recipes-opie/opie-connmansettings/opie-connmansettings.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Opie Network Settings application using ConnMan as a backend"
+SECTION = "opie/settings"
+LICENSE = "GPLv2"
+# FIXME stopgap until split archives have license files included
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+APPNAME = "connmansettings"
+
+RDEPENDS_${PN} += "connman"
+
+S = "${WORKDIR}/settings"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
diff --git a/recipes-opie/opie-connmansettings/opie-connmansettings_git.bb b/recipes-opie/opie-connmansettings/opie-connmansettings_git.bb
new file mode 100644
index 0000000..e9836a8
--- /dev/null
+++ b/recipes-opie/opie-connmansettings/opie-connmansettings_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/net/connman/settings \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"