aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-06-18 19:26:03 -0400
committerKhem Raj <raj.khem@gmail.com>2018-06-18 16:42:54 -0700
commit029ad49c25315cc7f05e1e3ec5f494c5e57ce885 (patch)
tree613f6f1bc04a6b0c38b4aaa489650302bea3628d /meta-xfce
parentce57958f46f1920f345f4793d5c27a42318c9ee9 (diff)
downloadmeta-openembedded-029ad49c25315cc7f05e1e3ec5f494c5e57ce885.tar.gz
xfce4: package libtool files if they are installed
This is a partial revert of commit 2ad5ceafa53f [various classes recipes: Remove FILES entries for dbg/dev packages] to restore the packaging of libtool (.la) files. It is generally recommended to include 'remove-libtool' in your distro features to purge libtool files as a do_install postfunc for all recipes, as is the documented recommendation for handling of libtool files (unless the .la have been determined to be absolutely necessary, in which case a recipe can use the REMOVE_LIBTOOL_LA to prevent the cleanup). However, if the 'remove-libtool' distro feature is not specified we need to ensure that if after a recipe completes do_install() and there are libtool files present in the image, we must package them or we will hit 'installed-vs-shipped' QA issues. NOTE: that even with respect to libtool files this is not a 1:1 partial revert of commit 2ad5ceafa53f, adjustments are made according to the current state of the build today. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/classes/thunar-plugin.bbclass2
-rw-r--r--meta-xfce/classes/xfce-panel-plugin.bbclass1
-rw-r--r--meta-xfce/recipes-apps/orage/orage_4.12.1.bb2
-rw-r--r--meta-xfce/recipes-multimedia/parole/parole_1.0.1.bb2
-rw-r--r--meta-xfce/recipes-xfce/gtk-xfce-engine/gtk-xfce-engine_3.2.0.bb5
-rw-r--r--meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb4
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb2
-rw-r--r--meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb4
8 files changed, 21 insertions, 1 deletions
diff --git a/meta-xfce/classes/thunar-plugin.bbclass b/meta-xfce/classes/thunar-plugin.bbclass
index 692f121d86..76b0e72332 100644
--- a/meta-xfce/classes/thunar-plugin.bbclass
+++ b/meta-xfce/classes/thunar-plugin.bbclass
@@ -7,3 +7,5 @@ DEPENDS += "thunar"
SRC_URI = "http://archive.xfce.org/src/thunar-plugins/${BPN}/${@'${PV}'[0:3]}/${BPN}-${PV}.tar.bz2"
FILES_${PN} += "${libdir}/thunarx-3/*.so"
+
+FILES_${PN}-dev += "${libdir}/thunarx-3/*.la"
diff --git a/meta-xfce/classes/xfce-panel-plugin.bbclass b/meta-xfce/classes/xfce-panel-plugin.bbclass
index fbc754c182..29c1245caa 100644
--- a/meta-xfce/classes/xfce-panel-plugin.bbclass
+++ b/meta-xfce/classes/xfce-panel-plugin.bbclass
@@ -11,3 +11,4 @@ FILES_${PN} += "${datadir}/xfce4/panel/plugins/"
FILES_${PN} += "${libdir}/xfce4/panel-plugins/*.so"
FILES_${PN} += "${libdir}/xfce4/panel/plugins/*.so"
+FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la" \ No newline at end of file
diff --git a/meta-xfce/recipes-apps/orage/orage_4.12.1.bb b/meta-xfce/recipes-apps/orage/orage_4.12.1.bb
index 22af379a7c..eb9da2dffa 100644
--- a/meta-xfce/recipes-apps/orage/orage_4.12.1.bb
+++ b/meta-xfce/recipes-apps/orage/orage_4.12.1.bb
@@ -15,4 +15,4 @@ PACKAGECONFIG[notify] = "--enable-libnotify,--disable-libnotify,libnotify"
PACKAGES =+ "xfce4-orageclock-plugin"
FILES_${PN} += "${datadir}/dbus-1"
FILES_xfce4-orageclock-plugin = "${libdir}/xfce4/panel/plugins/*.so ${datadir}/xfce4/panel/plugins"
-
+FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la"
diff --git a/meta-xfce/recipes-multimedia/parole/parole_1.0.1.bb b/meta-xfce/recipes-multimedia/parole/parole_1.0.1.bb
index 7e11b7718c..2b4e97490d 100644
--- a/meta-xfce/recipes-multimedia/parole/parole_1.0.1.bb
+++ b/meta-xfce/recipes-multimedia/parole/parole_1.0.1.bb
@@ -34,3 +34,5 @@ FILES_${PN} += " \
${datadir}/appdata \
${libdir}/parole-0/*.so \
"
+
+FILES_${PN}-dev += "${libdir}/parole-0/*.la"
diff --git a/meta-xfce/recipes-xfce/gtk-xfce-engine/gtk-xfce-engine_3.2.0.bb b/meta-xfce/recipes-xfce/gtk-xfce-engine/gtk-xfce-engine_3.2.0.bb
index aae07e1e20..805e893f79 100644
--- a/meta-xfce/recipes-xfce/gtk-xfce-engine/gtk-xfce-engine_3.2.0.bb
+++ b/meta-xfce/recipes-xfce/gtk-xfce-engine/gtk-xfce-engine_3.2.0.bb
@@ -21,5 +21,10 @@ FILES_${PN} += "${libdir}/gtk-2.0/*/engines/*.so"
FILES_gtk3-xfce-engine += "${libdir}/gtk-3.0/*/theming-engines/*.so"
FILES_${PN}-themes += "${datadir}/themes"
+FILES_${PN}-dev += " \
+ ${libdir}/gtk-2.0/*/engines/*.la \
+ ${libdir}/gtk-3.0/*/theming-engines/*.la \
+"
+
RDEPENDS_${PN} += "${PN}-themes"
RDEPENDS_gtk3-xfce-engine += "${PN}-themes"
diff --git a/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb b/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb
index 6113150583..9d2669475f 100644
--- a/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb
+++ b/meta-xfce/recipes-xfce/tumbler/tumbler_0.2.0.bb
@@ -26,3 +26,7 @@ FILES_${PN} += "${datadir}/dbus-1/services \
${libdir}/tumbler-1/plugins/*.so \
${libdir}/tumbler-1/plugins/cache/*.so \
"
+
+FILES_${PN}-dev += "${libdir}/tumbler-1/plugins/*.la \
+ ${libdir}/tumbler-1/plugins/cache/*.la \
+"
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb
index f1b4504b27..f1abf66755 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.13.3.bb
@@ -32,6 +32,8 @@ PACKAGES =+ "${PN}-gtk3"
FILES_${PN} += "${libdir}/xfce4/panel/migrate \
${libdir}/xfce4/panel/wrapper-1.0"
+FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la"
+
FILES_${PN}-gtk3 = " \
${libdir}/libxfce4panel-2.0${SOLIBS} \
${libdir}/xfce4/panel/wrapper-2.0 \
diff --git a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb
index 899edbf0ae..712597bcad 100644
--- a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb
+++ b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.12.1.bb
@@ -27,4 +27,8 @@ FILES_${PN} += " \
${datadir}/polkit-1 \
"
+FILES_${PN} += " \
+ ${libdir}/xfce4/session/splash-engines/*.la \
+"
+
RDEPENDS_${PN} += "machine-host"