aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorSergey Kizunov <sergey.kizunov@ni.com>2018-08-29 13:14:55 +0300
committerKhem Raj <raj.khem@gmail.com>2018-08-29 18:18:14 -0700
commit34653626984832b1832e1009d19a72f1e1776553 (patch)
treea95a8cdcd2b67c575b503f475dc54dcd5b3da0cf /meta-python
parent2b5fb4f8178cc685dab6719eb02f2e43b80beec0 (diff)
downloadmeta-openembedded-34653626984832b1832e1009d19a72f1e1776553.tar.gz
python-pytest-helpers-namespace: add recipe
This plugin does not provide any helpers to pytest, it does, however, provide a helpers namespace in pytest which enables you to register helper functions in your conftest.py to be used within your tests without having to import them. Signed-off-by: Sergey Kizunov <sergey.kizunov@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb b/meta-python/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb
new file mode 100644
index 0000000000..afca48702d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest-helpers-namespace_2016.7.10.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "This plugin does not provide any helpers to pytest, it does, however, provide a helpers namespace in pytest which enables you to register helper functions in your conftest.py to be used within your tests without having to import them."
+HOMEPAGE = "https://github.com/saltstack/pytest-helpers-namespace"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=71fac4dfeee99c39c51f617e9486237c"
+
+SRC_URI[md5sum] = "80fe3e515f640b1459709b539f6b857e"
+SRC_URI[sha256sum] = "d8bdb017c0f7271699c08850b6b12e1ce9e52913cbd4461b5febd21082a29113"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ python-pytest \
+ "