aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-03 17:39:33 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-16 21:33:05 -0800
commit11ed42e08f2085b0986dfe38199e9e0c87791a4b (patch)
tree4f5893d8d6d1dea05de39f51c41ec94768e5065e /meta-python
parentd619965394cd2f0785c4aaf1539cb5fc13efce29 (diff)
downloadmeta-openembedded-11ed42e08f2085b0986dfe38199e9e0c87791a4b.tar.gz
python-jsonpatch: add a python3 version of the recipe
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpatch.inc12
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpatch_1.20.bb14
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonpatch_1.20.bb6
3 files changed, 20 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch.inc b/meta-python/recipes-devtools/python/python-jsonpatch.inc
new file mode 100644
index 0000000000..8653de9be0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonpatch.inc
@@ -0,0 +1,12 @@
+SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
+
+inherit pypi
+
+SRC_URI[md5sum] = "b82b9ecad4cdef86bf0b88cbdbf7a8b9"
+SRC_URI[sha256sum] = "b12594a0cfe634bdd2a5c027250af2dd84932d493568e88ae722871edc3eb02d"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-json ${PYTHON_PN}-jsonpointer ${PYTHON_PN}-netclient ${PYTHON_PN}-re ${PYTHON_PN}-stringold"
+
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch_1.20.bb b/meta-python/recipes-devtools/python/python-jsonpatch_1.20.bb
index a28294a9dc..e45699a6d6 100644
--- a/meta-python/recipes-devtools/python/python-jsonpatch_1.20.bb
+++ b/meta-python/recipes-devtools/python/python-jsonpatch_1.20.bb
@@ -1,12 +1,2 @@
-SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x"
-HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
-
-inherit pypi setuptools
-
-SRC_URI[md5sum] = "b82b9ecad4cdef86bf0b88cbdbf7a8b9"
-SRC_URI[sha256sum] = "b12594a0cfe634bdd2a5c027250af2dd84932d493568e88ae722871edc3eb02d"
-
-RDEPENDS_${PN} += "${PYTHON_PN}-json ${PYTHON_PN}-jsonpointer ${PYTHON_PN}-netclient ${PYTHON_PN}-re ${PYTHON_PN}-stringold"
-
+inherit setuptools
+require python-jsonpatch.inc
diff --git a/meta-python/recipes-devtools/python/python3-jsonpatch_1.20.bb b/meta-python/recipes-devtools/python/python3-jsonpatch_1.20.bb
new file mode 100644
index 0000000000..eb55934858
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonpatch_1.20.bb
@@ -0,0 +1,6 @@
+inherit setuptools3
+require python-jsonpatch.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-enum \
+"