aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-15 15:38:47 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-17 08:57:30 -0700
commitfbc457f68799b56e1d37f55d857083d7075ae207 (patch)
tree6957ead72e3272a60a2dee9297b078d3a39eedf9 /meta-python/recipes-devtools/python
parent37616b499381e8a96309425fd92ba938b7cf3ee3 (diff)
downloadmeta-openembedded-fbc457f68799b56e1d37f55d857083d7075ae207.tar.gz
python3-psutil: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-psutil.inc22
-rw-r--r--meta-python/recipes-devtools/python/python3-psutil_5.7.0.bb25
2 files changed, 23 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-psutil.inc b/meta-python/recipes-devtools/python/python-psutil.inc
deleted file mode 100644
index dfb33e8dcf..0000000000
--- a/meta-python/recipes-devtools/python/python-psutil.inc
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "A cross-platform process and system utilities module for Python"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
-
-SRC_URI[md5sum] = "ed7b0f11ed214bcabbe76b7cf52f3ae3"
-SRC_URI[sha256sum] = "685ec16ca14d079455892f25bd124df26ff9137664af445563c1bd36629b5e0e"
-
-PACKAGES =+ "${PN}-tests"
-
-FILES_${PN}-tests += " \
- ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
- ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
-"
-
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-shell \
- ${PYTHON_PN}-threading \
- ${PYTHON_PN}-xml \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-psutil_5.7.0.bb b/meta-python/recipes-devtools/python/python3-psutil_5.7.0.bb
index c1969ea657..170819d59a 100644
--- a/meta-python/recipes-devtools/python/python3-psutil_5.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-psutil_5.7.0.bb
@@ -1,4 +1,25 @@
+SUMMARY = "A cross-platform process and system utilities module for Python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
+
+SRC_URI[md5sum] = "ed7b0f11ed214bcabbe76b7cf52f3ae3"
+SRC_URI[sha256sum] = "685ec16ca14d079455892f25bd124df26ff9137664af445563c1bd36629b5e0e"
+
inherit pypi setuptools3
-require python-psutil.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-netclient"
+PACKAGES =+ "${PN}-tests"
+
+FILES_${PN}-tests += " \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
+ ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
+"
+
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-netclient \
+"
+
+BBCLASSEXTEND = "native nativesdk"