aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-15 15:49:26 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-17 08:57:38 -0700
commitbfadb14ecf8c48528a9d822cdba3be9494116d51 (patch)
tree11e7c7434903456c83938a8f07cdb86187f9fa83 /meta-python/recipes-devtools/python
parent491eaf90ddd9d31ccf6bcd893805b982490c99ac (diff)
downloadmeta-openembedded-bfadb14ecf8c48528a9d822cdba3be9494116d51.tar.gz
python3-protobuf: Upgrade 3.11.3 -> 3.12.2
Upgrade to relase 3.12.2. Depends on the upgrade of protobuf to 3.12.3 in meta-oe. The new release for Python brings: - [experimental] Added proto3 presence support. - [experimental] fast import protobuf module, only works with cpp generated code linked in. - Truncate 'float' fields to 4 bytes of precision in setters for pure-Python implementation. - Fixed a memory leak in C++ bindings. - Added a deprecation warning when code tries to create Descriptor objects directly. - Fix unintended comparison between bytes and string in descriptor.py. - Avoid printing excess digits for float fields in TextFormat. - Remove Python 2.5 syntax compatibility from the proto compiler generated _pb2.py module code. - Drop 3.3, 3.4 and use single version docker images for all python tests. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-protobuf_3.12.2.bb (renamed from meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb b/meta-python/recipes-devtools/python/python3-protobuf_3.12.2.bb
index a4c9d6699b..03d0b0c603 100644
--- a/meta-python/recipes-devtools/python/python3-protobuf_3.11.3.bb
+++ b/meta-python/recipes-devtools/python/python3-protobuf_3.12.2.bb
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de8
inherit pypi setuptools3
-SRC_URI[md5sum] = "eeda7dea65fc94e560fc9a8180eb1872"
-SRC_URI[sha256sum] = "c77c974d1dadf246d789f6dad1c24426137c9091e930dbf50e0a29c1fcf00b1f"
+SRC_URI[md5sum] = "b4336acee38ebe915b6e72fe8c5bce7b"
+SRC_URI[sha256sum] = "49ef8ab4c27812a89a76fa894fe7a08f42f2147078392c0dee51d4a444ef6df5"
# http://errors.yoctoproject.org/Errors/Details/184715/
# Can't find required file: ../src/google/protobuf/descriptor.proto