aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorShlomi Vaknin <shlomi.39sd@gmail.com>2020-08-06 10:48:27 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-10 10:55:03 -0700
commit8c57f89686268f29861ea66027c5ec007267c460 (patch)
tree18abb23d5d99e4dd7270b1c7246f009ca218989b /meta-python/recipes-devtools/python
parent51f97cee9e301a7ecaf5400e6540b914795d33ba (diff)
downloadmeta-openembedded-8c57f89686268f29861ea66027c5ec007267c460.tar.gz
python3-ipython: add recipe
Signed-off-by: Shlomi Vaknin <shlomi.39sd@gmail.com> Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipython_7.17.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipython_7.17.0.bb b/meta-python/recipes-devtools/python/python3-ipython_7.17.0.bb
new file mode 100644
index 0000000000..ddcddd60b8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipython_7.17.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "IPython: Productive Interactive Computing"
+HOMEPAGE = "https://ipython.org"
+AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
+
+PYPI_PACKAGE = "ipython"
+
+SRC_URI[md5sum] = "1f2257d771de9d2fb40d9e3cfcea429d"
+SRC_URI[sha256sum] = "b70974aaa2674b05eb86a910c02ed09956a33f2dd6c71afc60f0b128a77e7f28"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-jedi \
+ ${PYTHON_PN}-decorator \
+ ${PYTHON_PN}-pickleshare \
+ ${PYTHON_PN}-traitlets \
+ ${PYTHON_PN}-prompt-toolkit \
+ ${PYTHON_PN}-pygments \
+ ${PYTHON_PN}-backcall \
+ ${PYTHON_PN}-pydoc \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-pexpect \
+ ${PYTHON_PN}-unixadmin \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-sqlite3 \
+"
+
+inherit setuptools3 pypi