aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorShlomi Vaknin <shlomi.39sd@gmail.com>2020-08-06 10:45:58 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-10 10:57:53 -0700
commit4062cec6f2936123250c644a96e56372f6e3cbe2 (patch)
tree3fbe5b2dfa3408e7d65ca4a78f63fead2ac0bfef /meta-python/recipes-devtools/python
parentc5054be65378cf95ae3f4541cd351d95a5a6a75a (diff)
downloadmeta-openembedded-4062cec6f2936123250c644a96e56372f6e3cbe2.tar.gz
python3-jedi: add recipe
Signed-off-by: Shlomi Vaknin <shlomi.39sd@gmail.com> Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-jedi_0.17.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jedi_0.17.2.bb b/meta-python/recipes-devtools/python/python3-jedi_0.17.2.bb
new file mode 100644
index 0000000000..aa5e698740
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jedi_0.17.2.bb
@@ -0,0 +1,14 @@
+SUMMARY = "An autocompletion tool for Python that can be used for text editors."
+HOMEPAGE = "https://github.com/davidhalter/jedi"
+AUTHOR = "David Halter <davidhalter88@gmail.com>"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5ed06eebfcb244cd66ebf6cef9c23ab4"
+
+PYPI_PACKAGE = "jedi"
+
+SRC_URI[md5sum] = "f012668907d76cebe9c4766f3b806fcf"
+SRC_URI[sha256sum] = "86ed7d9b750603e4ba582ea8edc678657fb4007894a12bcf6f4bb97892f31d20"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-parso"
+
+inherit setuptools3 pypi