aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2018-03-06 17:58:47 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-16 19:27:54 -0700
commit4598769a96980b756b3489ac71ed46a075cfabd7 (patch)
treeecdae6f7a618de786a3bd9a62ddfcc1ccb73ad3a /meta-oe
parent806cad5df9482899ad11c5402748fb12569748ec (diff)
downloadmeta-openembedded-4598769a96980b756b3489ac71ed46a075cfabd7.tar.gz
openbox: Improve handling of openbox-session / gnome-openbox-session
Without providing an alternative for x-session-manager we cannot drop openbox into the standard x11 images and have openbox take over as the session manager. Add openbox-session to ${PN}-core as well as an ALTERNATIVE line for it. Set the priority based on how other session managers do this. As we also have openbox-gnome-session move this from the full package and in to ${PN}-gnome. Cc: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Tom Rini <trini@konsulko.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb b/meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb
index b354ae7a1b..c35a0c7238 100644
--- a/meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb
+++ b/meta-oe/recipes-graphics/openbox/openbox_3.6.1.bb
@@ -16,9 +16,11 @@ inherit autotools gettext update-alternatives pkgconfig distro_features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
-ALTERNATIVE_${PN}-core = "x-window-manager"
+ALTERNATIVE_${PN}-core = "x-window-manager x-session-manager"
ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/openbox"
ALTERNATIVE_PRIORITY[x-window-manager] = "10"
+ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/openbox-session"
+ALTERNATIVE_PRIORITY[x-session-manager] = "100"
PACKAGECONFIG ??= ""
PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
@@ -38,7 +40,7 @@ python populate_packages_prepend() {
}
RDEPENDS_${PN} += "${PN}-core ${PN}-config ${PN}-theme-clearlooks"
-FILES_${PN}-core = "${bindir}/openbox ${libdir}/*${SOLIBS}"
+FILES_${PN}-core = "${bindir}/openbox ${bindir}/openbox-session ${libdir}/*${SOLIBS}"
FILES_${PN}-lxde += "${datadir}/lxde/ \
${datadir}/lxpanel \
@@ -46,6 +48,7 @@ FILES_${PN}-lxde += "${datadir}/lxde/ \
${datadir}/icons"
FILES_${PN}-gnome += " \
+ ${bindir}/openbox-gnome-session \
${datadir}/gnome \
${datadir}/gnome-session \
"