aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorchangqing.li@windriver.com <changqing.li@windriver.com>2018-07-05 11:28:58 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-05 10:19:03 -0700
commit7041cdd3b47b410b59a0b0dea92a1b831224e461 (patch)
tree4dbeeff652a3852acd401c004a9941969d14170a /meta-networking
parent215ac2480564fda29b40721aaa8c887a04c918f8 (diff)
downloadmeta-openembedded-7041cdd3b47b410b59a0b0dea92a1b831224e461.tar.gz
drbd-utils: add submodule drbd-headers into SRC_URI
1. add submodule drbd-headers into SRC_URI drbd-headers is git submodule of drbd-utils, so drbd-headers's code will not fetch during do_fetch. but it will get during do_compile(there is a logic in drbd-utils's makefile to do this), but if during do_compile, network is broken, fetch drbd-headers will fail, then do_compile will fail since missing header file. 2. add patch for fix drbd init script Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch43
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb7
2 files changed, 48 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch
new file mode 100644
index 0000000000..c0f3adf240
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch
@@ -0,0 +1,43 @@
+Subject: drbd-tools: only rmmod if DRBD is a module
+
+Account for the case if the DRBD drive is built into
+the kernel. Otherwise, errors, like the following,
+will occur:
+
+root@localhost:~# /etc/init.d/drbd stop
+ Stopping all DRBD resources: ERROR: Module drbd
+ does not exist in /proc/modules
+
+Upstream-Status: Submitted [https://github.com/LINBIT/drbd-utils/pull/2]
+
+Signed-off-by: Aws Ismail <aws.ismail@windriver.com>
+Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
+
+[ refresh to 8.4.4: squash Aws' and Jason's patches ]
+Signed-off-by: Michel Thebeau <michel.thebeau@windriver.com>
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
+
+---
+ scripts/drbd | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/scripts/drbd b/scripts/drbd
+index 20bf628..de589dc 100755
+--- a/scripts/drbd
++++ b/scripts/drbd
+@@ -241,7 +241,9 @@ case "$1" in
+ if [ -d /sys/module/drbd/holders ]; then
+ (cd /sys/module/drbd/holders; for tr in *; do [ -d ${tr} ] && ${RMMOD} ${tr}; done)
+ fi
+- $RMMOD drbd && break
++ if [ ! -z "$(cat /proc/modules | grep -w drbd)" ]; then
++ $RMMOD drbd && break
++ fi
+ fi
+ done
+ run_hook stop
+--
+1.9.1
+
diff --git a/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb b/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb
index d6e913f00a..98d4a49c7f 100644
--- a/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb
+++ b/meta-networking/recipes-support/drbd/drbd-utils_9.4.0.bb
@@ -8,10 +8,13 @@ SECTION = "admin"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
-SRC_URI = "git://github.com/LINBIT/drbd-utils \
+SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils \
+ git://github.com/LINBIT/drbd-headers;name=drbd-headers;destsuffix=git/drbd-headers \
+ file://0001-drbd-drbd-tools-only-rmmod-if-DRBD-is-a-module.patch \
"
# v9.4.0
-SRCREV = "eff6423ee72931aa0f8d0eb51742acee7c7cd3e1"
+SRCREV_drbd-utils = "eff6423ee72931aa0f8d0eb51742acee7c7cd3e1"
+SRCREV_drbd-headers = "d9ef0576d0f29992e0539ed7ca14d4f12658cd25"
S = "${WORKDIR}/git"