aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLi Zhou <li.zhou@windriver.com>2017-12-19 09:31:56 +0800
committerArmin Kuster <akuster808@gmail.com>2017-12-27 07:25:03 -0800
commiteaa4b4baa61813ef29fa436c0a1f863fbfc6a94e (patch)
tree2b8d1459ffffba04f1b3636af8ce3c58f0856347
parentc186045e8b753efb343b16518c907d5c97c90335 (diff)
downloadmeta-openembedded-eaa4b4baa61813ef29fa436c0a1f863fbfc6a94e.tar.gz
vim: Security Advisory - vim - CVE-2017-17087
Porting the patch from <https://github.com/vim/vim/commit/ 5a73e0ca54c77e067c3b12ea6f35e3e8681e8cf8> to solve CVE-2017-17087. Signed-off-by: Li Zhou <li.zhou@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/vim/files/CVE-2017-17087.patch70
-rw-r--r--meta-oe/recipes-support/vim/vim_8.0.0983.bb1
2 files changed, 71 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch b/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch
new file mode 100644
index 0000000000..937b9ba317
--- /dev/null
+++ b/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch
@@ -0,0 +1,70 @@
+From 9c11f80339372b7aa2f43153d574f2b5abb79708 Mon Sep 17 00:00:00 2001
+From: Li Zhou <li.zhou@windriver.com>
+Date: Sun, 17 Dec 2017 23:09:35 -0800
+Subject: [PATCH] vim: patch 8.0.1263: others can read the swap file if a user
+ is careless
+
+Problem: Others can read the swap file if a user is careless with his
+ primary group.
+Solution: If the group permission allows for reading but the world
+ permissions doesn't, make sure the group is right.
+
+Upstream-Status: Backport
+CVE: CVE-2017-17087
+Signed-off-by: Li Zhou <li.zhou@windriver.com>
+---
+ src/fileio.c | 24 +++++++++++++++++++++++-
+ src/version.c | 2 ++
+ 2 files changed, 25 insertions(+), 1 deletion(-)
+
+diff --git a/src/fileio.c b/src/fileio.c
+index f54fb8465..2c7740af9 100644
+--- a/src/fileio.c
++++ b/src/fileio.c
+@@ -716,7 +716,29 @@ readfile(
+ /* Set swap file protection bits after creating it. */
+ if (swap_mode > 0 && curbuf->b_ml.ml_mfp != NULL
+ && curbuf->b_ml.ml_mfp->mf_fname != NULL)
+- (void)mch_setperm(curbuf->b_ml.ml_mfp->mf_fname, (long)swap_mode);
++ {
++ char_u *swap_fname = curbuf->b_ml.ml_mfp->mf_fname;
++
++ /*
++ * If the group-read bit is set but not the world-read bit, then
++ * the group must be equal to the group of the original file. If
++ * we can't make that happen then reset the group-read bit. This
++ * avoids making the swap file readable to more users when the
++ * primary group of the user is too permissive.
++ */
++ if ((swap_mode & 044) == 040)
++ {
++ stat_T swap_st;
++
++ if (mch_stat((char *)swap_fname, &swap_st) >= 0
++ && st.st_gid != swap_st.st_gid
++ && fchown(curbuf->b_ml.ml_mfp->mf_fd, -1, st.st_gid)
++ == -1)
++ swap_mode &= 0600;
++ }
++
++ (void)mch_setperm(swap_fname, (long)swap_mode);
++ }
+ #endif
+ }
+
+diff --git a/src/version.c b/src/version.c
+index a5cb078f0..5c0df475f 100644
+--- a/src/version.c
++++ b/src/version.c
+@@ -770,6 +770,8 @@ static char *(features[]) =
+ static int included_patches[] =
+ { /* Add new patch number below this line */
+ /**/
++ 1263,
++/**/
+ 983,
+ /**/
+ 982,
+--
+2.11.0
+
diff --git a/meta-oe/recipes-support/vim/vim_8.0.0983.bb b/meta-oe/recipes-support/vim/vim_8.0.0983.bb
index 407ce5e730..f2edd5168b 100644
--- a/meta-oe/recipes-support/vim/vim_8.0.0983.bb
+++ b/meta-oe/recipes-support/vim/vim_8.0.0983.bb
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=eea32ac1424bba14096736a
SRC_URI = "git://github.com/vim/vim.git \
file://disable_acl_header_check.patch;patchdir=.. \
file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \
+ file://CVE-2017-17087.patch;patchdir=.. \
"
SRCREV = "3f9a1ff141412e9e85f7dff47d02946cb9be9228"