aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-19 22:05:03 -0700
committerKhem Raj <raj.khem@gmail.com>2019-07-21 09:31:09 -0700
commitca98c7044579762f773da7dd731fadb48e7a70e7 (patch)
treee555548a4597be6c35fb39cf92dae08a79538008
parent3982dc5b1994ffcc52336b02fbd2c44db164dd82 (diff)
downloadmeta-openembedded-ca98c7044579762f773da7dd731fadb48e7a70e7.tar.gz
librelp: Pass Wno-error to compiler
After autoconf-archive was upgraded to 2019.01.06 it started to add extra warning flags via WARN_CFLAGS along with -Werror which means that now compiler could be stricter and break the build if any of the new warnings are flagged The difference is old WARN_CFLAGS='-fno-strict-aliasing -Wimplicit-function-declaration -Wold-style-definition -Wjump-misses-init -Werror -Wno-suggest-attribute=format -Wunused-parameter -Wmissing-field-initializers' new WARN_CFLAGS='-fno-strict-aliasing -Wimplicit-function-declaration -Wold-style-definition -Wjump-misses-init -Wall -Wextra -Wundef -Wwrite-strings -Wpointer-arith -Wmissing-declarations -Wredundant-decls -Wno-unused-parameter -Wno-missing-field-initializers -Wformat=2 -Wcast-align -Wformat-nonliteral -Wformat-security -Wsign-compare -Wstrict-aliasing -Wshadow -Winline -Wpacked -Wmissing-format-attribute -Wmissing-noreturn -Winit-self -Wmissing-include-dirs -Wunused-but-set-variable -Warray-bounds -Wreturn-type -Wswitch-enum -Wswitch-default -Wduplicated-cond -Wduplicated-branches -Wlogical-op -Wrestrict -Wnull-dereference -Wdouble-promotion -pedantic -Wunused-parameter -Wmissing-field-initializers -Werror -Wno-suggest-attribute=format -Wunused-parameter -Wmissing-field-initializers' Hence we started seing build failure like https://errors.yoctoproject.org/Errors/Details/252684/ This fix just turns off warnings-as-errors so build can still go on, if we need to fix the warnings they still are present in log.do_compile Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Cc: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta-oe/recipes-extended/rsyslog/librelp_1.4.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/librelp_1.4.0.bb b/meta-oe/recipes-extended/rsyslog/librelp_1.4.0.bb
index 9e57dd520d..16c63a7523 100644
--- a/meta-oe/recipes-extended/rsyslog/librelp_1.4.0.bb
+++ b/meta-oe/recipes-extended/rsyslog/librelp_1.4.0.bb
@@ -14,3 +14,5 @@ SRCREV = "e96443dda3c080fa991decec26bc4ac98d24b9a2"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
+
+CPPFLAGS += "-Wno-error"