aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2019-05-22 14:52:46 +0800
committerKhem Raj <raj.khem@gmail.com>2019-05-23 08:26:14 -0700
commitc45eb9fe2169f433e45e1fb67b525cd05a9b4a47 (patch)
treeb595e87a6a66b78d4e41f2594be66c231d885096
parent4a7b942dc129a49eb91f5415f2a2cce48657f8cc (diff)
downloadmeta-openembedded-c45eb9fe2169f433e45e1fb67b525cd05a9b4a47.tar.gz
pm-graph: add recipe
This tool suite is designed to assist kernel and OS developers in optimizing their linux stack's suspend/resume & boot time. For more details and usage, please check: https://01.org/pm-graph Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
new file mode 100644
index 0000000000..de2d46dcaf
--- /dev/null
+++ b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.3.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Timing analysis tools for suspend/resume/boot"
+DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \
+in optimizing their linux stack's suspend/resume & boot time."
+HOMEPAGE = "https://01.org/pm-graph"
+LICENSE = "GPL-2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
+
+SRCREV = "5be9a16547234cef5aca8bfaccd920490ea1cfa7"
+SRC_URI = "git://github.com/intel/pm-graph.git"
+S = "${WORKDIR}/git"
+
+COMPATIBLE_HOST='(i.86|x86_64).*'
+EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D}"
+
+do_install() {
+ oe_runmake install
+}
+
+RDEPENDS_${PN} += "python-core python-threading python-datetime python-subprocess python-compression"