aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJian Liu <jian.liu@windriver.com>2015-11-02 01:05:46 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2015-11-30 12:53:48 -0500
commitb6d4390d7b9a0b7ef14879e0ddd6ea2a3114e530 (patch)
tree1d72bd5d4b5358adfc7ce2931926a0950770e0d9
parentfb80c7f2f3152c521cd46c19338ec78978b7d730 (diff)
downloadmeta-openembedded-b6d4390d7b9a0b7ef14879e0ddd6ea2a3114e530.tar.gz
ypbind-mt: set path of ypdomainname in ypbind script
The script ypbind will cause error if using ypdomainname command provided by busybox. So add RDEPENDCY on yp-tools and change the path of ypdomainname. Signed-off-by: Jian Liu <jian.liu@windriver.com> Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r--meta-networking/recipes-support/nis/files/ypbind.init11
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_1.38.bb2
2 files changed, 8 insertions, 5 deletions
diff --git a/meta-networking/recipes-support/nis/files/ypbind.init b/meta-networking/recipes-support/nis/files/ypbind.init
index 244dc78bca..669c19ca08 100644
--- a/meta-networking/recipes-support/nis/files/ypbind.init
+++ b/meta-networking/recipes-support/nis/files/ypbind.init
@@ -26,6 +26,7 @@
YPBIND_BIN=/usr/sbin/ypbind
pidfile=/var/run/ypbind.pid
+YPDOMAINNAME_bin=/usr/bin/ypdomainname
[ -f /etc/default/ypbind ] && . /etc/default/ypbind
@@ -34,14 +35,14 @@ case "$1" in
echo -n "Starting ypbind"
## If the domainname is not set, skip starting of ypbind
## and return with "program not configured"
- /bin/ypdomainname >/dev/null 2>&1
- if [ $? -ne 0 -o -z "`/bin/ypdomainname 2>/dev/null`" ]; then
+ $YPDOMAINNAME_bin >/dev/null 2>&1
+ if [ $? -ne 0 -o -z "`$YPDOMAINNAME_bin 2>/dev/null`" ]; then
if [ -f /etc/defaultdomain ]; then
XDOMAINNAME=`cat /etc/defaultdomain`
- /bin/ypdomainname "$XDOMAINNAME"
+ $YPDOMAINNAME_bin "$XDOMAINNAME"
fi
- /bin/ypdomainname >/dev/null 2>&1
- if [ $? -ne 0 -o -z "`/bin/ypdomainname 2>/dev/null`" ]; then
+ $YPDOMAINNAME_bin >/dev/null 2>&1
+ if [ $? -ne 0 -o -z "`$YPDOMAINNAME_bin 2>/dev/null`" ]; then
# Tell the user this has skipped
echo -n " . . . . . . . . . . No domainname set"
# service is not configured
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb b/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
index 5702cd6a5f..d113b82e89 100644
--- a/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
+++ b/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
@@ -21,6 +21,8 @@ DEPENDS = " \
yp-tools \
${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
"
+RDEPENDS_${PN} += "yp-tools"
+
# ypbind-mt now provides all the functionality of ypbind
# and is used in place of it.
PROVIDES += "ypbind"