aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-12-20 14:29:50 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-27 07:25:02 -0800
commitb08b570c8624303acbb6bb064a7bda466a679df4 (patch)
treee7d9a95b1476069f3426e4a1b7e73dfdeb16d11f
parentaad2b954382f8711e76ebf193c7db07d53a1dab7 (diff)
downloadmeta-openembedded-b08b570c8624303acbb6bb064a7bda466a679df4.tar.gz
python-twisted: avoid downloading build dependencies
setup.py will attempt to download python-incremental, as it is not present in the sysroot. This is at the least wrong since some random version of python-incremental will be used to build against (akin to host contamination) and at most a build failure (when network access is unavailable). So make python-incrementa-native available and a DEPENDS. Unfortunately python-incremental has a dependency on python-twisted and vice versa. So we need to forcefully break this circular dependency. Fortunately this doesn't affect the build of python-twisted. Unfortunately if anyone else attempts to use python-incremental-native there might be issues should it ever run the code that does the import of twisted. This is not an issue now and a comment has been added to hopefully make this issue known to anyone else coming along at a later time. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-incremental.inc6
-rw-r--r--meta-python/recipes-devtools/python/python-twisted.inc4
2 files changed, 10 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-incremental.inc b/meta-python/recipes-devtools/python/python-incremental.inc
index 3675458688..b63fac9791 100644
--- a/meta-python/recipes-devtools/python/python-incremental.inc
+++ b/meta-python/recipes-devtools/python/python-incremental.inc
@@ -12,3 +12,9 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-twisted \
${PYTHON_PN}-click \
"
+
+# -native is needed to build python[3]-twisted, however, we need to take steps to
+# prevent a circular dependency. The build apparently does not use the part of
+# python-incremental which uses python-twisted, so this hack is OK.
+RDEPENDS_${PYTHON_PN}-incremental-native_remove = "${PYTHON_PN}-twisted-native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-twisted.inc b/meta-python/recipes-devtools/python/python-twisted.inc
index 0dd584f9fe..6480ad54f9 100644
--- a/meta-python/recipes-devtools/python/python-twisted.inc
+++ b/meta-python/recipes-devtools/python/python-twisted.inc
@@ -39,6 +39,10 @@ PACKAGES =+ "\
${PN}-bin \
"
+DEPENDS += " \
+ ${PYTHON_PN}-incremental-native \
+"
+
RDEPENDS_${PN} = "\
${PN}-bin \
${PN}-core \