aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-03 09:23:41 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-16 21:36:53 -0800
commitaf308c17f6f35e3f331e52ba5e23b1dba004473f (patch)
treee0775758954620528ef886348b57b5f258a67304
parent04ea59d2c5d27f8e467be292edcd396aa795cb57 (diff)
downloadmeta-openembedded-af308c17f6f35e3f331e52ba5e23b1dba004473f.tar.gz
python-protobuf: update to version 3.5.1
Add RDEPENDS to work on minimal python and don't pull in python-six in python3 Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-protobuf_3.5.1.bb (renamed from meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb)0
-rw-r--r--meta-python/recipes-devtools/python/python3-protobuf_3.5.1.bb (renamed from meta-python/recipes-devtools/python/python3-protobuf_3.4.0.bb)0
3 files changed, 13 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python-protobuf.inc b/meta-python/recipes-devtools/python/python-protobuf.inc
index 2f59ef98b6..07346d372c 100644
--- a/meta-python/recipes-devtools/python/python-protobuf.inc
+++ b/meta-python/recipes-devtools/python/python-protobuf.inc
@@ -2,15 +2,24 @@ DESCRIPTION = "Protocol Buffers"
HOMEPAGE = "https://developers.google.com/protocol-buffers/"
SECTION = "devel/python"
-RDEPENDS_${PN} = "python-six"
-
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
inherit pypi
-SRC_URI[md5sum] = "bfc0c61c156a995e909521697e755780"
-SRC_URI[sha256sum] = "ef02609ef445987976a3a26bff77119c518e0915c96661c3a3b17856d0ef6374"
+SRC_URI[md5sum] = "27b52592aab674f96a1762d66d48a57c"
+SRC_URI[sha256sum] = "95b78959572de7d7fafa3acb718ed71f482932ddddddbd29ba8319c10639d863"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-unittest \
+"
# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb b/meta-python/recipes-devtools/python/python-protobuf_3.5.1.bb
index f04fc489f0..f04fc489f0 100644
--- a/meta-python/recipes-devtools/python/python-protobuf_3.4.0.bb
+++ b/meta-python/recipes-devtools/python/python-protobuf_3.5.1.bb
diff --git a/meta-python/recipes-devtools/python/python3-protobuf_3.4.0.bb b/meta-python/recipes-devtools/python/python3-protobuf_3.5.1.bb
index 781d1dc4da..781d1dc4da 100644
--- a/meta-python/recipes-devtools/python/python3-protobuf_3.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-protobuf_3.5.1.bb