aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-10-12 16:26:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-21 18:20:45 +0200
commit8ba31c9ba214802b1305aabbc0be0353cba0bc3e (patch)
tree4d4ce6c120ce73bb6cb997ccda19669b5b7e2d3d
parentf882db657b3c88ea105d3e47342902a5325ce3cd (diff)
downloadmeta-openembedded-8ba31c9ba214802b1305aabbc0be0353cba0bc3e.tar.gz
gpsd, mongodb: use PACKAGECONFIG_CONFARGS instead of now empty EXTRA_OECONF
* this will fix mongodb build for x86 http://errors.yoctoproject.org/Errors/Details/90392/ which was failing because of missing --wiredtiger=off in qemux86 builds * also we can drop DISABLE_STATIC, because now it's not leaking through EXTRA_OECONF * it will also resolve again autodetected dependencies on bluez, qt and tcmalloc as shown in bitbake -e output: env.gpsd-before:EXTRA_OESCONS=" sysroot=/OE/build/oe-core/tmp-glibc/sysroots/qemux86 libQgpsmm='false' debug='true' strip='false' chrpath='yes' systemd='true' " env.gpsd-after:EXTRA_OESCONS=" sysroot=/OE/build/oe-core/tmp-glibc/sysroots/qemux86 libQgpsmm='false' debug='true' strip='false' chrpath='yes' systemd='true' bluez='true' qt='no' " env.mongodb-before:EXTRA_OESCONS="--prefix=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0/image/usr LIBPATH=/OE/build/oe-core/tmp-glibc/sysroots/qemux86/usr/lib LINKFLAGS='-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed' \ CXXFLAGS='-O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0=/usr/src/debug/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0 -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/sysroots/x86_64-linux= -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/sysroots/qemux86= -fvisibility-inlines-hidden' \ TARGET_ARCH=i586 --ssl --disable-warnings-as-errors --use-system-pcre --use-system-zlib --js-engine=none --nostrip mongod mongos" env.mongodb-after:EXTRA_OESCONS="--prefix=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0/image/usr LIBPATH=/OE/build/oe-core/tmp-glibc/sysroots/qemux86/usr/lib LINKFLAGS='-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed' \ CXXFLAGS='-O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0=/usr/src/debug/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0 -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/sysroots/x86_64-linux= -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/sysroots/qemux86= -fvisibility-inlines-hidden' \ TARGET_ARCH=i586 --ssl --disable-warnings-as-errors --use-system-pcre --use-system-zlib --js-engine=none --nostrip --use-system-tcmalloc --wiredtiger=off mongod mongos" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb3
-rw-r--r--meta-oe/recipes-support/mongodb/mongodb_git.bb3
2 files changed, 2 insertions, 4 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
index 4ff6d917d0..b7b89689b5 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
@@ -46,9 +46,8 @@ EXTRA_OESCONS = " \
strip='false' \
chrpath='yes' \
systemd='${SYSTEMD_OESCONS}' \
- ${EXTRA_OECONF} \
+ ${PACKAGECONFIG_CONFARGS} \
"
-DISABLE_STATIC = ""
# this cannot be used, because then chrpath is not found and only static lib is built
# target=${HOST_SYS}
diff --git a/meta-oe/recipes-support/mongodb/mongodb_git.bb b/meta-oe/recipes-support/mongodb/mongodb_git.bb
index cb6c1b3434..f1a65550e4 100644
--- a/meta-oe/recipes-support/mongodb/mongodb_git.bb
+++ b/meta-oe/recipes-support/mongodb/mongodb_git.bb
@@ -43,9 +43,8 @@ EXTRA_OESCONS = "--prefix=${D}${prefix} \
--use-system-zlib \
--js-engine=none \
--nostrip \
- ${EXTRA_OECONF} \
+ ${PACKAGECONFIG_CONFARGS} \
mongod mongos"
-DISABLE_STATIC = ""
scons_do_compile() {
${STAGING_BINDIR_NATIVE}/scons ${PARALLEL_MAKE} ${EXTRA_OESCONS} || \