aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-22 11:07:06 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 11:10:25 -0800
commit82eef4ef6297805db1a25bef5ea9d26f8f87b4b4 (patch)
tree78250ea9b22d0e44244c967289e66ac9e4644342
parent324448b359873d4c8e6f8f90c2cad71fa1a36239 (diff)
downloadmeta-openembedded-82eef4ef6297805db1a25bef5ea9d26f8f87b4b4.tar.gz
guider: Build only when meta-py2 is in mix
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/guider/guider_3.9.6.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta-oe/recipes-devtools/guider/guider_3.9.6.bb b/meta-oe/recipes-devtools/guider/guider_3.9.6.bb
index c8ddb15080..397e0cb9a3 100644
--- a/meta-oe/recipes-devtools/guider/guider_3.9.6.bb
+++ b/meta-oe/recipes-devtools/guider/guider_3.9.6.bb
@@ -16,7 +16,7 @@ SRCREV = "fef25c41efb9bde0614ea477d0b90bd9565ae0b4"
S = "${WORKDIR}/git"
R = "${RECIPE_SYSROOT}"
-inherit distutils3
+inherit distutils
GUIDER_OBJ = "guider.pyc"
GUIDER_SCRIPT = "guider"
@@ -31,5 +31,9 @@ do_install() {
install -v -m 0755 ${STAGING_LIBDIR_NATIVE}/python${PYTHON_BASEVERSION}/site-packages/${BPN}/${GUIDER_OBJ} ${D}${datadir}/${BPN}/${GUIDER_OBJ}
}
-RDEPENDS_${PN} = "python3-ctypes python3-shell \
- python3-json python3-subprocess"
+RDEPENDS_${PN} = "python-ctypes python-shell \
+ python-json python-subprocess"
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}