aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-06-30 10:21:31 -0700
committerKhem Raj <raj.khem@gmail.com>2020-06-30 10:23:46 -0700
commit81ee0b68fa32bcd60e1226f612ec63b1e672f263 (patch)
tree48eec7c1d2f2e57966abfe5f61fde61b1f692b15
parent86770ea397b0f0a709fd449ee0c7a36cb4987407 (diff)
downloadmeta-openembedded-81ee0b68fa32bcd60e1226f612ec63b1e672f263.tar.gz
lirc: Inherit distutils-common-base
This helps in compiling the python pieces in this package, which uses setup.py to build but does not have ldshared set correctly, inheriting distutils-common-base provides the minimum needed environment for the python module build Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.1.bb b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.1.bb
index 2843cdf95c..b68303241e 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.1.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-connectivity/lirc/lirc_0.10.1.bb
@@ -29,7 +29,7 @@ SYSTEMD_SERVICE_${PN}-exec = "irexec.service"
SYSTEMD_AUTO_ENABLE_lirc = "enable"
SYSTEMD_AUTO_ENABLE_lirc-exec = "enable"
-inherit autotools pkgconfig systemd python3native
+inherit autotools pkgconfig systemd python3native distutils-common-base
PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--without-systemdsystemunitdir,systemd"
PACKAGECONFIG[x11] = "--with-x,--with-x=no,libx11,"