aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Ulrich <kaiu@gmx.de>2015-03-18 11:20:53 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-21 16:42:30 +0100
commit7e2911a0e99ff66adb7999931107761298a5b3fe (patch)
treedca2ffc74c3cc3a9e106e4430e4dcdac7b72e16b
parente758f9d38ffd39822fa3614ffdd7e38729387f18 (diff)
downloadmeta-openembedded-7e2911a0e99ff66adb7999931107761298a5b3fe.tar.gz
smstools3: Add smstools3 to meta-oe/recipes-connectivity
Signed-off-by: Kai Ulrich <kaiu@gmx.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/smstools3/smstools3/sms_binpath_and_psops.patch19
-rw-r--r--meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb45
2 files changed, 64 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/smstools3/smstools3/sms_binpath_and_psops.patch b/meta-oe/recipes-connectivity/smstools3/smstools3/sms_binpath_and_psops.patch
new file mode 100644
index 0000000000..ffcaa09716
--- /dev/null
+++ b/meta-oe/recipes-connectivity/smstools3/smstools3/sms_binpath_and_psops.patch
@@ -0,0 +1,19 @@
+Index: smstools3/scripts/sms3
+===================================================================
+--- smstools3.orig/scripts/sms3 2010-05-04 11:21:44.000000000 +0200
++++ smstools3/scripts/sms3 2015-02-22 20:05:51.615074469 +0100
+@@ -24,11 +24,11 @@
+ # Logfile can also be defined in here:
+ LOGFILE="/var/log/smsd.log"
+
+-DAEMON=/usr/local/bin/smsd
++DAEMON=/usr/bin/smsd
+ # A program which turns power off for couple of seconds:
+-RESETMODEMS=/usr/local/bin/smsd_resetmodems
++RESETMODEMS=/usr/bin/smsd_resetmodems
+ NAME=smsd
+-PSOPT="-e"
++PSOPT=""
+ ECHO=echo
+ case `uname` in
+ *BSD|Darwin)
diff --git a/meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb b/meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb
new file mode 100644
index 0000000000..7a72a1ed3b
--- /dev/null
+++ b/meta-oe/recipes-connectivity/smstools3/smstools3_3.1.15.bb
@@ -0,0 +1,45 @@
+SUMMARY = "SMS Gateway software"
+DESCRIPTION = "The SMS Server Tools 3 is a SMS Gateway software which can send and receive short messages through GSM modems and mobile phones."
+SECTION = "console/network"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4d21efa1bb2a186360dde4035f860682"
+HOMEPAGE = "http://smstools3.kekekasvi.com"
+
+SRC_URI = "http://smstools3.kekekasvi.com/packages/${BP}.tar.gz \
+ file://sms_binpath_and_psops.patch"
+
+SRC_URI[md5sum] = "0241ef60e646fac1a06254a848e61ed7"
+SRC_URI[sha256sum] = "ed00ffaeaa312a5b4f969f4e97a64603a866bbe16e393ea02f5bf05234814d59"
+
+
+S = "${WORKDIR}/${PN}"
+
+RDEPENDS_${PN} = "bash"
+INITSCRIPT_NAME = "sms3"
+INITSCRIPT_PARAMS = "defaults"
+
+inherit update-rc.d
+
+do_install () {
+
+ install -d ${D}${bindir}
+ install -m 755 ${S}/src/smsd "${D}${bindir}/smsd"
+
+ install -m 755 ${S}/scripts/sendsms "${D}${bindir}/sendsms"
+ install -m 755 ${S}/scripts/sms2html "${D}${bindir}/sms2html"
+ install -m 755 ${S}/scripts/sms2unicode "${D}${bindir}/sms2unicode"
+ install -m 755 ${S}/scripts/unicode2sms "${D}${bindir}/unicode2sms"
+
+ install -d ${D}${sysconfdir}
+ install -m 644 ${S}/examples/smsd.conf.easy "${D}${sysconfdir}/smsd.conf"
+
+ install -d "${D}${localstatedir}/spool"
+ install -d "${D}${localstatedir}/spool/sms"
+ install -d "${D}${localstatedir}/spool/sms/incoming"
+ install -d "${D}${localstatedir}/spool/sms/outgoing"
+ install -d "${D}${localstatedir}/spool/sms/checked"
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${S}/scripts/sms3 "${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}"
+
+}